summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-02-22 15:47:35 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-02-22 15:47:35 +0000
commit77bb6229b256597b390b1e8dfba4b7e773076fcf (patch)
tree33dc3ee5f45f97d3dcbad8d2da3a8c7fbb13ff2b /app-text/cb2bib
parentFix building with jpeg-8 (previous declaration of jpeg_mem_src and jpeg_mem_d... (diff)
downloadgentoo-2-77bb6229b256597b390b1e8dfba4b7e773076fcf.tar.gz
gentoo-2-77bb6229b256597b390b1e8dfba4b7e773076fcf.tar.bz2
gentoo-2-77bb6229b256597b390b1e8dfba4b7e773076fcf.zip
Version bump (bug #306319)
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-text/cb2bib')
-rw-r--r--app-text/cb2bib/ChangeLog7
-rw-r--r--app-text/cb2bib/cb2bib-1.3.7.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-text/cb2bib/ChangeLog b/app-text/cb2bib/ChangeLog
index f9e121fd2a71..5b64ceb9ad20 100644
--- a/app-text/cb2bib/ChangeLog
+++ b/app-text/cb2bib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/cb2bib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.1 2010/01/06 20:02:58 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.2 2010/02/22 15:47:35 ayoy Exp $
+
+*cb2bib-1.3.7 (22 Feb 2010)
+
+ 22 Feb 2010; Dominik Kapusta <ayoy@gentoo.org> +cb2bib-1.3.7.ebuild:
+ Version bump (bug #306319)
*cb2bib-1.3.6 (06 Jan 2010)
diff --git a/app-text/cb2bib/cb2bib-1.3.7.ebuild b/app-text/cb2bib/cb2bib-1.3.7.ebuild
new file mode 100644
index 000000000000..3f18b94af6dd
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-1.3.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/cb2bib-1.3.7.ebuild,v 1.1 2010/02/22 15:47:35 ayoy Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="http://www.molspaces.com/cb2bib/"
+SRC_URI="http://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +lzo +poll"
+
+DEPEND="x11-libs/qt-webkit:4
+ lzo? ( dev-libs/lzo )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ echo "CONFIG += ordered" >> "${PN}.pro" || die "patching project file failed"
+ sed -i 's:\.\./COPYRIGHT \.\.\/LICENSE::' src/src.pro || die "sed src.pro failed"
+}
+
+src_configure() {
+ # Custom configure script has only few options, so call ./configure manually...
+ # We need to unset QTDIR here, else we may end up with qt3 if it is installed.
+ # TODO: remove QTDIR when qt3 goes away
+ QTDIR="" ./configure \
+ $(use_enable lzo) \
+ $(use_enable poll cbpoll) \
+ --disable-qmake-call \
+ --qmakepath /usr/bin/qmake \
+ --prefix /usr \
+ --bindir /usr/bin \
+ --datadir /usr/share \
+ --desktopdatadir /usr/share/applications \
+ --icondir /usr/share/pixmaps \
+ || die "cb2bib-provided configure failed"
+
+ eqmake4 $(cat qmake-additional-args)
+}
+
+pkg_postinst() {
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler-utils - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+}