summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-04-29 06:21:51 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-04-29 06:21:51 +0000
commitc4dceeed1a478fe293f3edba7855cfec309cdd8f (patch)
tree123d1a52c4a085de85e8af8baf1a215e007a946e /app-text/cb2bib
parentVersion bump (diff)
downloadgentoo-2-c4dceeed1a478fe293f3edba7855cfec309cdd8f.tar.gz
gentoo-2-c4dceeed1a478fe293f3edba7855cfec309cdd8f.tar.bz2
gentoo-2-c4dceeed1a478fe293f3edba7855cfec309cdd8f.zip
Version bump. Thanks to Samuli Suominen (ssuominen@g.o) for reporting (bug #317137).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/cb2bib')
-rw-r--r--app-text/cb2bib/ChangeLog8
-rw-r--r--app-text/cb2bib/cb2bib-1.4.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/app-text/cb2bib/ChangeLog b/app-text/cb2bib/ChangeLog
index 5526c335c5b1..e4d3b5ad1a8e 100644
--- a/app-text/cb2bib/ChangeLog
+++ b/app-text/cb2bib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/cb2bib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.4 2010/03/04 09:27:19 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.5 2010/04/29 06:21:51 ayoy Exp $
+
+*cb2bib-1.4.0 (29 Apr 2010)
+
+ 29 Apr 2010; Dominik Kapusta <ayoy@gentoo.org> +cb2bib-1.4.0.ebuild:
+ Version bump. Thanks to Samuli Suominen (ssuominen@g.o) for reporting (bug
+ #317137).
04 Mar 2010; Christian Faulhammer <fauli@gentoo.org> cb2bib-1.3.6.ebuild:
stable x86, bug 306379
diff --git a/app-text/cb2bib/cb2bib-1.4.0.ebuild b/app-text/cb2bib/cb2bib-1.4.0.ebuild
new file mode 100644
index 000000000000..5e11774991af
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-1.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/cb2bib-1.4.0.ebuild,v 1.1 2010/04/29 06:21:51 ayoy Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="http://www.molspaces.com/cb2bib/"
+SRC_URI="http://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +lzo +poll"
+
+DEPEND="x11-libs/qt-webkit:4
+ lzo? ( dev-libs/lzo )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ echo "CONFIG += ordered" >> "${PN}.pro" || die "patching project file failed"
+ sed -i 's:\.\./COPYRIGHT \.\.\/LICENSE::' src/src.pro || die "sed src.pro failed"
+}
+
+src_configure() {
+ # Custom configure script has only few options, so call ./configure manually...
+ # We need to unset QTDIR here, else we may end up with qt3 if it is installed.
+ # TODO: remove QTDIR when qt3 goes away
+ QTDIR="" ./configure \
+ $(use_enable lzo) \
+ $(use_enable poll cbpoll) \
+ --disable-qmake-call \
+ --qmakepath /usr/bin/qmake \
+ --prefix /usr \
+ --bindir /usr/bin \
+ --datadir /usr/share \
+ --desktopdatadir /usr/share/applications \
+ --icondir /usr/share/pixmaps \
+ || die "cb2bib-provided configure failed"
+
+ eqmake4 $(cat qmake-additional-args)
+}
+
+pkg_postinst() {
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler-utils - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+}