summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-08 00:44:31 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-08 00:44:31 +0000
commit7e7cda33f57402529f2042d248b409dce94ad967 (patch)
tree0d6ea205f020d9e49790602132b05ee6e207bcab /app-text/csvfix
parentVersion bump. (diff)
downloadgentoo-2-7e7cda33f57402529f2042d248b409dce94ad967.tar.gz
gentoo-2-7e7cda33f57402529f2042d248b409dce94ad967.tar.bz2
gentoo-2-7e7cda33f57402529f2042d248b409dce94ad967.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-text/csvfix')
-rw-r--r--app-text/csvfix/ChangeLog10
-rw-r--r--app-text/csvfix/csvfix-1.6.ebuild44
-rw-r--r--app-text/csvfix/files/csvfix-1.6-makefile.patch69
3 files changed, 121 insertions, 2 deletions
diff --git a/app-text/csvfix/ChangeLog b/app-text/csvfix/ChangeLog
index ead5b9bd7418..63b39b644766 100644
--- a/app-text/csvfix/ChangeLog
+++ b/app-text/csvfix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/csvfix
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/csvfix/ChangeLog,v 1.7 2012/05/31 18:27:12 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/csvfix/ChangeLog,v 1.8 2014/12/08 00:44:31 radhermit Exp $
+
+*csvfix-1.6 (08 Dec 2014)
+
+ 08 Dec 2014; Tim Harder <radhermit@gentoo.org> +csvfix-1.6.ebuild,
+ +files/csvfix-1.6-makefile.patch:
+ Version bump.
31 May 2012; Tim Harder <radhermit@gentoo.org>
-files/csvfix-1.00c-make.patch, -csvfix-1.10a.ebuild,
diff --git a/app-text/csvfix/csvfix-1.6.ebuild b/app-text/csvfix/csvfix-1.6.ebuild
new file mode 100644
index 000000000000..4c9817fd2cb8
--- /dev/null
+++ b/app-text/csvfix/csvfix-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/csvfix/csvfix-1.6.ebuild,v 1.1 2014/12/08 00:44:31 radhermit Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs versionator vcs-snapshot
+
+MY_PV="$(delete_all_version_separators)"
+DESCRIPTION="A stream editor for manipulating CSV files"
+HOMEPAGE="http://code.google.com/p/csvfix/"
+SRC_URI="https://bitbucket.org/neilb/csvfix/get/version-${PV}.tar.bz2 -> ${P}.tar.bz2
+ doc? ( https://bitbucket.org/neilb/csvfix/downloads/csvfix_man_html_${MY_PV}0.zip )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.10a-tests.patch
+
+ edos2unix $(find csvfix/tests -type f)
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" AR="$(tc-getAR)" lin
+}
+
+src_test() {
+ cd ${PN}/tests
+ chmod +x run1 runtests
+ ./runtests || die "tests failed"
+}
+
+src_install() {
+ dobin csvfix/bin/csvfix
+ use doc && dohtml -r "${WORKDIR}"/${PN}${MY_PV}/*
+}
diff --git a/app-text/csvfix/files/csvfix-1.6-makefile.patch b/app-text/csvfix/files/csvfix-1.6-makefile.patch
new file mode 100644
index 000000000000..aaee2aa003f7
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.6-makefile.patch
@@ -0,0 +1,69 @@
+--- neilb-csvfix-e804a794d175/alib/Makefile
++++ neilb-csvfix-e804a794d175/alib/Makefile
+@@ -2,12 +2,12 @@
+ # Copyright (C) 2009 Neil Butterworth
+
+ OUT = lib/alib.a
++AR = ar
+ CCTYPE = gcc
+ IDIR = inc
+ ODIR = obj
+-XDIR = expat
+ SDIR = src
+-INC = -Iinc -Iexpat
++INC = -Iinc
+
+ cc.gcc = g++
+ cc.clang = clang++ -std=c++11 -stdlib=libc++
+@@ -26,9 +26,6 @@
+ _WINOBJS = a_db.o a_dir.o a_opsys.o a_winerr.o
+ WINOBJS = $(patsubst %,$(ODIR)/%,$(_WINOBJS))
+
+-_EXPAT = xmlparse.o xmlrole.o xmltok.o xmltok_impl.o xmltok_ns.o
+-EXPAT = $(patsubst %,$(ODIR)/%,$(_EXPAT))
+-
+ $(ODIR)/%.o: $(SDIR)/%.cpp $(IDIR)/%.h
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+@@ -36,10 +33,10 @@
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+ win: $(OBJS) $(EXPAT) $(WINOBJS)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ lin: $(OBJS) $(EXPAT)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ .PHONY: clean
+ clean:
+--- neilb-csvfix-e804a794d175/csvfix/Makefile
++++ neilb-csvfix-e804a794d175/csvfix/Makefile
+@@ -22,7 +22,7 @@
+
+ ALIB = ../alib/lib/alib.a
+ WINLIBS = ../alib/lib/alib.a -lodbc32
+-LINLIBS = ../alib/lib/alib.a
++LINLIBS = ../alib/lib/alib.a -lexpat
+
+ _OBJS = csved_atable.o \
+ csved_block.o \
+@@ -99,8 +99,7 @@
+ strip $(WINOUT)
+
+ $(LINOUT): $(OBJS) $(ALIB)
+- $(CC) -o $@ $^ $(LINLIBS)
+- strip $(LINOUT)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LINLIBS)
+
+ .PHONY: win
+ win:
+--- neilb-csvfix-e804a794d175/Makefile
++++ neilb-csvfix-e804a794d175/Makefile
+@@ -1,3 +1,5 @@
++CFLAGS += -std=c++11
++
+ ifndef COMSPEC
+ CLEAN = (cd alib; $(MAKE) clean) && (cd csvfix; $(MAKE) clean)
+ else