summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-01-20 18:38:36 +0000
committerPeter Volkov <pva@gentoo.org>2009-01-20 18:38:36 +0000
commit839cb2a8b8e0c96d0b0f6ffa3d6945938b4f4e65 (patch)
tree90e5b0d3e306742e3fc390f4400bb63a14b6cd59 /app-text/djvu
parentStable for HPPA (bug #245425). (diff)
downloadgentoo-2-839cb2a8b8e0c96d0b0f6ffa3d6945938b4f4e65.tar.gz
gentoo-2-839cb2a8b8e0c96d0b0f6ffa3d6945938b4f4e65.tar.bz2
gentoo-2-839cb2a8b8e0c96d0b0f6ffa3d6945938b4f4e65.zip
Bump to CVS snapshot as it fixes plugin crash and amd64.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-text/djvu')
-rw-r--r--app-text/djvu/ChangeLog9
-rw-r--r--app-text/djvu/djvu-3.5.21_p20090103.ebuild119
2 files changed, 126 insertions, 2 deletions
diff --git a/app-text/djvu/ChangeLog b/app-text/djvu/ChangeLog
index 70e6927f9264..edbb218a12ed 100644
--- a/app-text/djvu/ChangeLog
+++ b/app-text/djvu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/djvu
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.86 2008/12/01 21:23:48 ranger Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.87 2009/01/20 18:38:36 pva Exp $
+
+*djvu-3.5.21_p20090103 (20 Jan 2009)
+
+ 20 Jan 2009; Peter Volkov <pva@gentoo.org> +djvu-3.5.21_p20090103.ebuild:
+ Bump to CVS snapshot as it fixes plugin crash and amd64.
01 Dec 2008; Brent Baude <ranger@gentoo.org> djvu-3.5.21.ebuild:
stable ppc64, bug 244258
diff --git a/app-text/djvu/djvu-3.5.21_p20090103.ebuild b/app-text/djvu/djvu-3.5.21_p20090103.ebuild
new file mode 100644
index 000000000000..7e24e90bf671
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.21_p20090103.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.21_p20090103.ebuild,v 1.1 2009/01/20 18:38:36 pva Exp $
+
+EAPI=1
+inherit fdo-mime nsplugins flag-o-matic eutils multilib toolchain-funcs confutils
+
+MY_P="${PN}libre-${PV#*_p}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities."
+HOMEPAGE="http://djvu.sourceforge.net"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xml qt3 jpeg tiff debug threads nls nsplugin kde doc"
+
+RDEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( media-libs/tiff )
+ qt3? ( x11-libs/qt:3 )"
+DEPEND="${RDEPEND}
+ qt3? ( nsplugin? ( x11-libs/libXt ) )"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de en fr ja zh"
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ if ! use qt3; then
+ ewarn
+ ewarn "The standalone djvu viewer, djview, will not be compiled."
+ ewarn "Add \"qt3\" to your USE flags if you want it."
+ ewarn
+ fi
+
+ confutils_use_depend_all nsplugin qt3
+}
+
+src_compile() {
+ local I18N
+ if use nls; then
+ for X in ${LANGS}; do
+ if use linguas_${X}; then
+ I18N="${I18N} ${X}"
+ fi
+ done
+ I18N="${I18N# }"
+ if test -n "$I18N"; then
+ I18N="--enable-i18n=${I18N}"
+ else
+ I18N="--enable-i18n"
+ fi
+ else
+ I18N="--disable-i18n"
+ fi
+
+ # When enabling qt it must be compiled with threads. See bug #89544.
+ if use qt3 ; then
+ QTCONF=" --with-qt --enable-threads "
+ elif use threads ; then
+ QTCONF=" --without-qt --disable-djview --enable-threads "
+ else
+ QTCONF=" --without-qt --disable-djview --disable-threads "
+ fi
+
+ # We install all desktop files by hand.
+ econf --disable-desktopfiles \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ "${I18N}" \
+ $(use_enable debug) \
+ ${QTCONF}
+
+ if ! use nsplugin; then
+ sed -e 's:nsdejavu::' -i "${S}"/gui/Makefile || die
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" plugindir=/usr/$(get_libdir)/${PLUGINS_DIR} install
+
+ dodoc README TODO NEWS
+
+ use doc && cp -r doc/ "${D}"/usr/share/doc/${PF}
+
+ # Install desktop files.
+ cd desktopfiles
+ insinto /usr/share/icons/hicolor/22x22/mimetypes && newins hi22-djvu.png image-vnd.djvu.png || die
+ insinto /usr/share/icons/hicolor/32x32/mimetypes && newins hi32-djvu.png image-vnd.djvu.png || die
+ insinto /usr/share/icons/hicolor/48x48/mimetypes && newins hi48-djvu.png image-vnd.djvu.png || die
+ insinto /usr/share/mime/packages && doins djvulibre-mime.xml || die
+ if use kde ; then
+ insinto /usr/share/mimelnk/image && doins vnd.djvu.desktop || die
+ cp "${D}"/usr/share/mimelnk/image/{vnd.djvu.desktop,x-djvu.desktop}
+ sed -i -e 's:image/vnd.djvu:image/x-djvu:' "${D}"/usr/share/mimelnk/image/x-djvu.desktop
+ fi
+
+ if use qt3 ; then
+ insinto /usr/share/icons/hicolor/32x32/apps && newins hi32-djview3.png djvulibre-djview3.png || die
+ insinto /usr/share/applications/ && doins djvulibre-djview3.desktop || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}