summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-04 06:37:46 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-04 06:37:46 +0000
commit1b8c053c7a8b63d2e58d8c1c544be24326e51cf0 (patch)
tree5820ac9bb5b405419b0d269d4e4a7354385155fb /app-text/dos2unix
parentAdd dbus-1.3.0 to package.mask as it is a development version. Please (diff)
downloadgentoo-2-1b8c053c7a8b63d2e58d8c1c544be24326e51cf0.tar.gz
gentoo-2-1b8c053c7a8b63d2e58d8c1c544be24326e51cf0.tar.bz2
gentoo-2-1b8c053c7a8b63d2e58d8c1c544be24326e51cf0.zip
Version BUmp
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog9
-rw-r--r--app-text/dos2unix/dos2unix-5.1.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index b399d510bc86..646e09b3ec25 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.44 2010/03/22 07:36:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.45 2010/04/04 06:37:46 jlec Exp $
- 22 Mar 2010; <justin@gentoo.org> dos2unix-5.0.ebuild:
+*dos2unix-5.1 (04 Apr 2010)
+
+ 04 Apr 2010; Justin Lecher <jlec@gentoo.org> +dos2unix-5.1.ebuild:
+ Version Bump
+
+ 22 Mar 2010; <jlec@gentoo.org> dos2unix-5.0.ebuild:
HOMEPAGE fixed per 310643
21 Mar 2010; Fabian Groffen <grobian@gentoo.org> dos2unix-5.0.ebuild:
diff --git a/app-text/dos2unix/dos2unix-5.1.ebuild b/app-text/dos2unix/dos2unix-5.1.ebuild
new file mode 100644
index 000000000000..3c807b8a36fc
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.1.ebuild,v 1.1 2010/04/04 06:37:46 jlec Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="nls"
+
+DEPEND="virtual/libintl"
+RDEPEND="
+ ${DEPEND}
+ !app-text/hd2u
+ !app-text/unix2dos"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/^CC/s|=|?=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -i "${S}"/Makefile
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}"/usr \
+ $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=") \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}"/usr \
+ $(use nls || echo "ENABLE_NLS=") install \
+ || die "emake install failed"
+}