summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-09-26 14:27:26 +0000
committerJeroen Roovers <jer@gentoo.org>2012-09-26 14:27:26 +0000
commit88ee191ec578a1652c65e2ca5ce766dcc1d12bce (patch)
treedf4f95a243889f657ea2e16b585fbdaf89214703 /app-text/enscript
parentStable for amd64, wrt bug #427556 (diff)
downloadgentoo-2-88ee191ec578a1652c65e2ca5ce766dcc1d12bce.tar.gz
gentoo-2-88ee191ec578a1652c65e2ca5ce766dcc1d12bce.tar.bz2
gentoo-2-88ee191ec578a1652c65e2ca5ce766dcc1d12bce.zip
Version bump. Fix obsolete tail option in src/tests/passthrough.test.
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'app-text/enscript')
-rw-r--r--app-text/enscript/ChangeLog7
-rw-r--r--app-text/enscript/enscript-1.6.6.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-text/enscript/ChangeLog b/app-text/enscript/ChangeLog
index 086c33e9459e..6d72ad1d249f 100644
--- a/app-text/enscript/ChangeLog
+++ b/app-text/enscript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/enscript
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.64 2012/05/12 01:46:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.65 2012/09/26 14:27:26 jer Exp $
+
+*enscript-1.6.6 (26 Sep 2012)
+
+ 26 Sep 2012; Jeroen Roovers <jer@gentoo.org> +enscript-1.6.6.ebuild:
+ Version bump. Fix obsolete tail option in src/tests/passthrough.test.
12 May 2012; Alexis Ballier <aballier@gentoo.org> enscript-1.6.5.2-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6.ebuild
new file mode 100644
index 000000000000..b2319c0cef1b
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/enscript-1.6.6.ebuild,v 1.1 2012/09/26 14:27:26 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="powerful text-to-postscript converter"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/enscript/enscript.html"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="nls ruby"
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/enscript-1.6.4-ebuild.st.patch
+ epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
+ use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
+ sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO || die "dodoc failed"
+
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ebuild.st || die "doins ebuild.st failed"
+
+ if use ruby ; then
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ruby.st || die "doins ruby.st failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "Now, customize /etc/enscript.cfg."
+}