summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-04-08 21:31:57 +0000
committerRémi Cardona <remi@gentoo.org>2008-04-08 21:31:57 +0000
commit2a316aa45f3b247aa73c7b73bb7d50f8b3fc7250 (patch)
tree570408423e3ae80b6f1c0a95a8eb67146518885f /app-text/evince
parent(#195251) Fix build with --as-needed by always linking against dynamic librar... (diff)
downloadgentoo-2-2a316aa45f3b247aa73c7b73bb7d50f8b3fc7250.tar.gz
gentoo-2-2a316aa45f3b247aa73c7b73bb7d50f8b3fc7250.tar.bz2
gentoo-2-2a316aa45f3b247aa73c7b73bb7d50f8b3fc7250.zip
app-text/evince: Bump to 2.22.1.1, bugfix release, contains our dbus patch
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog7
-rw-r--r--app-text/evince/evince-2.22.1.1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 6b2a24f5f014..0d402cb9ea1c 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/evince
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.137 2008/04/02 15:02:25 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.138 2008/04/08 21:31:57 remi Exp $
+
+*evince-2.22.1.1 (08 Apr 2008)
+
+ 08 Apr 2008; Rémi Cardona <remi@gentoo.org> +evince-2.22.1.1.ebuild:
+ Bump to 2.22.1.1, bugfix release, contains our dbus patch
02 Apr 2008; Daniel Gryniewicz <dang@gentoo.org>
-files/evince-2.22.0-gtk-doc-die-die-die.patch, evince-2.22.0.ebuild:
diff --git a/app-text/evince/evince-2.22.1.1.ebuild b/app-text/evince/evince-2.22.1.1.ebuild
new file mode 100644
index 000000000000..d554d671a7c1
--- /dev/null
+++ b/app-text/evince/evince-2.22.1.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.22.1.1.ebuild,v 1.1 2008/04/08 21:31:57 remi Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus djvu doc dvi gnome keyring t1lib tiff"
+
+RDEPEND="
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.15.6
+ keyring? ( >=gnome-base/gnome-keyring-2.20.1 )
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libgnome-2.14
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=dev-libs/libxml2-2.5
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2
+ gnome? ( >=gnome-base/nautilus-2.10 )
+ >=app-text/poppler-bindings-0.6
+ dvi? (
+ virtual/tetex
+ t1lib? ( >=media-libs/t1lib-5.0.0 )
+ )
+ tiff? ( >=media-libs/tiff-3.6 )
+ djvu? ( >=app-text/djvu-3.5.17 )
+ >=app-text/libspectre-0.2.0"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=sys-devel/automake-1.9
+ >=dev-util/intltool-0.35
+ dev-util/gtk-doc-am
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+ELTCONF="--portage"
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --enable-comics
+ --enable-impress
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with keyring)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ $(use_enable gnome nautilus)"
+
+ if ! built_with_use app-text/poppler-bindings gtk; then
+ einfo "Please re-emerge app-text/poppler-bindings with the gtk USE flag set"
+ die "poppler-bindings needs gtk flag set"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+}