summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-12-17 17:38:34 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-12-17 17:38:34 +0000
commitc7bb17241709f9f186bd8787b643cf01dd4f159b (patch)
tree038304b205a6a76e4cea8634b6b722497c464f72 /app-text/evince
parentVersion bump. Fixes bug #156228 and bug #154493. (diff)
downloadgentoo-2-c7bb17241709f9f186bd8787b643cf01dd4f159b.tar.gz
gentoo-2-c7bb17241709f9f186bd8787b643cf01dd4f159b.tar.bz2
gentoo-2-c7bb17241709f9f186bd8787b643cf01dd4f159b.zip
Add actual configure switch for dbus; bug #158034
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog8
-rw-r--r--app-text/evince/evince-0.6.1-r1.ebuild82
-rw-r--r--app-text/evince/files/digest-evince-0.6.1-r13
-rw-r--r--app-text/evince/files/evince-0.6.1-dbus-switch.patch21
4 files changed, 113 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 1b90eed84884..30756da3eba2 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/evince
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.74 2006/12/17 00:20:00 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.75 2006/12/17 17:38:34 dang Exp $
+
+*evince-0.6.1-r1 (17 Dec 2006)
+
+ 17 Dec 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/evince-0.6.1-dbus-switch.patch, +evince-0.6.1-r1.ebuild:
+ Add actual configure switch for dbus; bug #158034
17 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org> evince-0.6.1.ebuild:
Stable on ppc wrt bug #156662.
diff --git a/app-text/evince/evince-0.6.1-r1.ebuild b/app-text/evince/evince-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..f52f26f2bdf7
--- /dev/null
+++ b/app-text/evince/evince-0.6.1-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-0.6.1-r1.ebuild,v 1.1 2006/12/17 17:38:34 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+LICENSE="GPL-2"
+
+IUSE="dbus djvu doc dvi gnome t1lib tiff"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dvi? (
+ virtual/tetex
+ t1lib? ( >=media-libs/t1lib-5.0.0 )
+ )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.33 ) ) )
+ tiff? ( >=media-libs/tiff-3.6 )
+ >=app-text/poppler-bindings-0.5.4
+ >=dev-libs/glib-2
+ >=gnome-base/gnome-vfs-2.0
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2
+ gnome-base/libgnome
+ || (
+ >=gnome-base/libgnomeprintui-2.6
+ >=x11-libs/gtk+-2.10
+ )
+ >=gnome-base/libgnomeui-2.14
+ gnome? ( >=gnome-base/nautilus-2.10 )
+ >=x11-libs/gtk+-2.8.15
+ gnome-base/gnome-keyring
+ djvu? ( >=app-text/djvu-3.5.17 )
+ virtual/ghostscript"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=sys-devel/automake-1.9
+ >=dev-util/intltool-0.35"
+
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+USE_DESTDIR="1"
+ELTCONF="--portage"
+
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ --enable-comics \
+ --enable-impress \
+ $(use_enable dbus) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable gnome nautilus)"
+
+ if ! built_with_use app-text/poppler-bindings gtk; then
+ einfo "Please re-emerge app-text/poppler-bindings with the gtk USE flag set"
+ die "poppler-bindings needs gtk flag set"
+ fi
+}
+
+src_unpack(){
+ unpack "${A}"
+ cd "${S}"
+
+ # Fix .desktop file so menu item shows up
+ epatch ${FILESDIR}/${PN}-0.5.3-display-menu.patch
+
+ # Make dbus actually switchable
+ epatch ${FILESDIR}/${P}-dbus-switch.patch
+
+ eautoreconf
+}
diff --git a/app-text/evince/files/digest-evince-0.6.1-r1 b/app-text/evince/files/digest-evince-0.6.1-r1
new file mode 100644
index 000000000000..498e46d52a0f
--- /dev/null
+++ b/app-text/evince/files/digest-evince-0.6.1-r1
@@ -0,0 +1,3 @@
+MD5 55a1d4af3cac209c7cfbe83b7ffcee1d evince-0.6.1.tar.bz2 1212271
+RMD160 ac94e1964f4f46e505fe945daa9de288c2587898 evince-0.6.1.tar.bz2 1212271
+SHA256 ee72f48ec0c76a8f44d8a6aed6759d43a147a9d5bb2b15f06460c4d6ef86025e evince-0.6.1.tar.bz2 1212271
diff --git a/app-text/evince/files/evince-0.6.1-dbus-switch.patch b/app-text/evince/files/evince-0.6.1-dbus-switch.patch
new file mode 100644
index 000000000000..701114e87af4
--- /dev/null
+++ b/app-text/evince/files/evince-0.6.1-dbus-switch.patch
@@ -0,0 +1,21 @@
+diff --exclude-from=/home/dang/.diffrc -up -ruN evince-0.6.1.orig/configure.ac evince-0.6.1/configure.ac
+--- evince-0.6.1.orig/configure.ac 2006-10-09 14:58:09.000000000 -0400
++++ evince-0.6.1/configure.ac 2006-12-17 11:41:10.000000000 -0500
+@@ -109,6 +109,9 @@ AM_CONDITIONAL(WITH_GTK_PRINT, test x$en
+
+
+ dnl ========= Check for DBUS
++AC_ARG_ENABLE(dbus,
++ [AC_HELP_STRING([--enable-dbus], [Compile with support for dbus])],enable_dbus="$enableval",enable_dbus=yes)
++if test "x$enable_dbus" != "xno"; then
+ PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED],
+ [enable_dbus=yes],[enable_dbus=no])
+ AC_SUBST([DBUS_CFLAGS])
+@@ -130,6 +133,7 @@ if test "x$enable_dbus" = "xyes" ; then
+ DBUS_VERSION=`$PKG_CONFIG --modversion dbus-glib-1 | sed 's/0\.\([[0-9]]*\)\.\{0,1\}\([[0-9]]*\)/\1/'`
+ AC_DEFINE_UNQUOTED(DBUS_VERSION, $DBUS_VERSION, [DBUS version.])
+ fi
++fi
+
+ SHELL_CFLAGS="$SHELL_CORE_CFLAGS $DBUS_CFLAGS"
+ SHELL_LIBS="$SHELL_CORE_LIBS $DBUS_LIBS -lz"