summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-07-10 10:46:29 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-07-10 10:46:29 +0000
commit27c00a3bd89d2524c854d164ef75e6a5566acecc (patch)
tree328c0bfa4ec4d0dbfed2218ccb39f12bc2ed31c9 /app-text/fbreader
parentDrop insecure versions (diff)
downloadgentoo-2-27c00a3bd89d2524c854d164ef75e6a5566acecc.tar.gz
gentoo-2-27c00a3bd89d2524c854d164ef75e6a5566acecc.tar.bz2
gentoo-2-27c00a3bd89d2524c854d164ef75e6a5566acecc.zip
Added casts to qreal (bug #515698), thanks to William Throwe <wtt6@cornell.edu>; added mimetypes to .desktop (bug #516794); depend on qtcore[ssl] (bug #462044); added -j1 (bug #484516)
(Portage version: 2.2.10/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'app-text/fbreader')
-rw-r--r--app-text/fbreader/ChangeLog11
-rw-r--r--app-text/fbreader/fbreader-0.99.4-r2.ebuild (renamed from app-text/fbreader/fbreader-0.99.4.ebuild)20
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch6
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch13
4 files changed, 45 insertions, 5 deletions
diff --git a/app-text/fbreader/ChangeLog b/app-text/fbreader/ChangeLog
index 26fb1300a148..8bcd1c0ed3e6 100644
--- a/app-text/fbreader/ChangeLog
+++ b/app-text/fbreader/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-text/fbreader
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/fbreader/ChangeLog,v 1.39 2014/04/14 09:03:36 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/fbreader/ChangeLog,v 1.40 2014/07/10 10:46:29 grozin Exp $
+
+*fbreader-0.99.4-r2 (10 Jul 2014)
+
+ 10 Jul 2014; Andrey Grozin <grozin@gentoo.org> -fbreader-0.99.4.ebuild,
+ +fbreader-0.99.4-r2.ebuild, +files/fbreader-0.99.4-mimetypes.patch,
+ +files/fbreader-0.99.4-qreal-cast.patch:
+ Added casts to qreal (bug #515698), thanks to William Throwe
+ <wtt6@cornell.edu>; added mimetypes to .desktop (bug #516794); depend on
+ qtcore[ssl] (bug #462044); added -j1 (bug #484516)
14 Apr 2014; Andrey Grozin <grozin@gentoo.org> metadata.xml:
Set maintainer to grozin
diff --git a/app-text/fbreader/fbreader-0.99.4.ebuild b/app-text/fbreader/fbreader-0.99.4-r2.ebuild
index ee4a963eddb1..18817f13b573 100644
--- a/app-text/fbreader/fbreader-0.99.4.ebuild
+++ b/app-text/fbreader/fbreader-0.99.4-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/fbreader/fbreader-0.99.4.ebuild,v 1.3 2013/03/02 19:42:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/fbreader/fbreader-0.99.4-r2.ebuild,v 1.1 2014/07/10 10:46:29 grozin Exp $
EAPI=5
@@ -12,7 +12,7 @@ SRC_URI="http://www.fbreader.org/files/desktop/${PN}-sources-${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="debug"
RDEPEND="
@@ -23,7 +23,7 @@ RDEPEND="
dev-db/sqlite
net-misc/curl
sys-libs/zlib
- dev-qt/qtcore:4
+ dev-qt/qtcore:4[ssl]
dev-qt/qtgui:4
"
DEPEND="${RDEPEND}
@@ -65,6 +65,18 @@ src_prepare() {
else
echo "TARGET_STATUS = release" >> makefiles/target.mk
fi
+
+ # bug #452636
+ epatch "${FILESDIR}"/${P}.patch
+ # bug #515698
+ epatch "${FILESDIR}"/${P}-qreal-cast.patch
+ # bug #516794
+ epatch "${FILESDIR}"/${P}-mimetypes.patch
+}
+
+src_compile() {
+ # bug #484516
+ emake -j1
}
src_install() {
diff --git a/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch b/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch
new file mode 100644
index 000000000000..0e4a2935d442
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-mimetypes.patch
@@ -0,0 +1,6 @@
+diff -r -U1 fbreader-0.99.4.orig/fbreader/desktop/desktop fbreader-0.99.4/fbreader/desktop/desktop
+--- fbreader-0.99.4.orig/fbreader/desktop/desktop 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/fbreader/desktop/desktop 2014-07-10 20:56:33.527638562 +0700
+@@ -23 +23,2 @@
+ Categories=Office;Viewer;Literature;
++MimeType=application/epub+zip;application/rtf;application/x-fictionbook+xml;application/x-zip-compressed-fb2;application/x-mobipocket-ebook;application/xhtml+xml;text/html;text/plain;
diff --git a/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch b/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch
new file mode 100644
index 000000000000..ffd21b2924f7
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-qreal-cast.patch
@@ -0,0 +1,13 @@
+diff -r -U1 fbreader-0.99.4.orig/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp fbreader-0.99.4/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp
+--- fbreader-0.99.4.orig/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2012-11-30 19:41:25.000000000 +0700
++++ fbreader-0.99.4/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2014-07-10 19:18:17.002886537 +0700
+@@ -88,3 +88,3 @@
+ void QtWaitingSpinner::setRoundness(qreal roundness) {
+- myRoundness = std::max(0.0, std::min(100.0, roundness));
++ myRoundness = std::max(static_cast<qreal>(0.0), std::min(static_cast<qreal>(100.0), roundness));
+ }
+@@ -150,3 +150,3 @@
+ qreal resultAlpha = color.alphaF() - gradation * distance;
+- resultAlpha = std::min(1.0, std::max(0.0, resultAlpha)); //if alpha is out of bound, force it to bounds
++ resultAlpha = std::min(static_cast<qreal>(1.0), std::max(static_cast<qreal>(0.0), resultAlpha)); //if alpha is out of bound, force it to bounds
+ color.setAlphaF(resultAlpha);