summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-07-19 17:36:12 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-07-19 17:36:12 +0000
commitf3f9681021b4c5c1ad73e88e0f3ba1fbbde45f4a (patch)
tree036d2b9f3a3bc27b5437a1ee31881c4cce5babc9 /app-text/goldendict
parentversion bump (diff)
downloadgentoo-2-f3f9681021b4c5c1ad73e88e0f3ba1fbbde45f4a.tar.gz
gentoo-2-f3f9681021b4c5c1ad73e88e0f3ba1fbbde45f4a.tar.bz2
gentoo-2-f3f9681021b4c5c1ad73e88e0f3ba1fbbde45f4a.zip
Fix build with GCC 4.7, wrt bug #426988. Thanks to Sven Eden <yamakuzure@gmx.net>.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-text/goldendict')
-rw-r--r--app-text/goldendict/ChangeLog8
-rw-r--r--app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch40
-rw-r--r--app-text/goldendict/goldendict-1.0.1.ebuild4
3 files changed, 49 insertions, 3 deletions
diff --git a/app-text/goldendict/ChangeLog b/app-text/goldendict/ChangeLog
index 73af18148c2e..d393d8fe7b83 100644
--- a/app-text/goldendict/ChangeLog
+++ b/app-text/goldendict/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/goldendict
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/ChangeLog,v 1.7 2012/05/04 03:33:14 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/ChangeLog,v 1.8 2012/07/19 17:36:12 kensington Exp $
+
+ 19 Jul 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/goldendict-1.0.1-gcc-4.7.patch, goldendict-1.0.1.ebuild:
+ Fix build with GCC 4.7, wrt bug #426988. Thanks to Sven Eden
+ <yamakuzure@gmx.net>.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> goldendict-1.0.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -49,4 +54,3 @@
+goldendict-0.9.0.ebuild, +files/goldendict-0.9.0-gcc4.4.patch,
+metadata.xml:
Initial ebuild of goldendict. Bug #264631
-
diff --git a/app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch b/app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch
new file mode 100644
index 000000000000..24995a221b3c
--- /dev/null
+++ b/app-text/goldendict/files/goldendict-1.0.1-gcc-4.7.patch
@@ -0,0 +1,40 @@
+From b00d081da20b9a6b257573c6b23a6bc640c4dab1 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Fri, 20 Jul 2012 03:27:38 +1000
+Subject: [PATCH] Fix build with GCC 4.7 by adding missing includes.
+
+---
+ processwrapper.cc | 4 ++++
+ qtsingleapplication/src/qtlocalpeer.cpp | 1 +
+ 2 files changed, 5 insertions(+)
+
+diff --git a/processwrapper.cc b/processwrapper.cc
+index f7f3f19..86b985d 100644
+--- a/processwrapper.cc
++++ b/processwrapper.cc
+@@ -2,6 +2,10 @@
+
+ #include <QtCore>
+
++#if defined(Q_OS_UNIX)
++#include <unistd.h>
++#endif
++
+ #ifdef Q_OS_WIN32
+
+ #include <windows.h>
+diff --git a/qtsingleapplication/src/qtlocalpeer.cpp b/qtsingleapplication/src/qtlocalpeer.cpp
+index 382d182..506c142 100644
+--- a/qtsingleapplication/src/qtlocalpeer.cpp
++++ b/qtsingleapplication/src/qtlocalpeer.cpp
+@@ -50,6 +50,7 @@ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {
+--
+1.7.11.1
+
diff --git a/app-text/goldendict/goldendict-1.0.1.ebuild b/app-text/goldendict/goldendict-1.0.1.ebuild
index 68b900727051..d7e273be4b85 100644
--- a/app-text/goldendict/goldendict-1.0.1.ebuild
+++ b/app-text/goldendict/goldendict-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/goldendict-1.0.1.ebuild,v 1.6 2012/05/04 03:33:14 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/goldendict-1.0.1.ebuild,v 1.7 2012/07/19 17:36:12 kensington Exp $
EAPI=3
LANGSLONG="ar_SA bg_BG cs_CZ de_DE el_GR it_IT lt_LT ru_RU uk_UA vi_VN zh_CN"
@@ -37,6 +37,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
src_prepare() {
qt4-r2_src_prepare