summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2009-05-26 04:40:29 +0000
committerSerkan Kaba <serkan@gentoo.org>2009-05-26 04:40:29 +0000
commit3327ec1705c465babdc65b0451e8f6c001d896fe (patch)
tree3f7a0d9a689ae9f9f8fbd507aecbb784df314c2d /app-text/gtkspell
parentFix quoting issue. (diff)
downloadgentoo-2-3327ec1705c465babdc65b0451e8f6c001d896fe.tar.gz
gentoo-2-3327ec1705c465babdc65b0451e8f6c001d896fe.tar.bz2
gentoo-2-3327ec1705c465babdc65b0451e8f6c001d896fe.zip
Revbump to fix critical error. Closes bug #270177
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/ChangeLog8
-rw-r--r--app-text/gtkspell/files/gtkspell-2.0.15-fix-null-list.patch15
-rw-r--r--app-text/gtkspell/gtkspell-2.0.15-r1.ebuild40
3 files changed, 62 insertions, 1 deletions
diff --git a/app-text/gtkspell/ChangeLog b/app-text/gtkspell/ChangeLog
index 964b580275af..3c53843ec8ed 100644
--- a/app-text/gtkspell/ChangeLog
+++ b/app-text/gtkspell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/gtkspell
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.76 2009/05/10 15:10:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.77 2009/05/26 04:40:29 serkan Exp $
+
+*gtkspell-2.0.15-r1 (26 May 2009)
+
+ 26 May 2009; Serkan Kaba <serkan@gentoo.org> +gtkspell-2.0.15-r1.ebuild,
+ +files/gtkspell-2.0.15-fix-null-list.patch:
+ Revbump to fix critical error. Closes bug #270177
10 May 2009; Jeroen Roovers <jer@gentoo.org> gtkspell-2.0.15.ebuild:
Stable for HPPA (bug #266665).
diff --git a/app-text/gtkspell/files/gtkspell-2.0.15-fix-null-list.patch b/app-text/gtkspell/files/gtkspell-2.0.15-fix-null-list.patch
new file mode 100644
index 000000000000..f35cea87327a
--- /dev/null
+++ b/app-text/gtkspell/files/gtkspell-2.0.15-fix-null-list.patch
@@ -0,0 +1,15 @@
+diff -Nur gtkspell-2.0.15/gtkspell/gtkspell.c gtkspell-2.0.15_patched/gtkspell/gtkspell.c
+--- gtkspell-2.0.15/gtkspell/gtkspell.c 2008-12-01 10:38:40.000000000 +0200
++++ gtkspell-2.0.15_patched/gtkspell/gtkspell.c 2009-05-17 14:50:09.000000000 +0300
+@@ -387,10 +387,9 @@
+ if (inside_more_submenu) gtk_menu_shell_append(GTK_MENU_SHELL(menu), mi);
+ else gtk_menu_shell_insert(GTK_MENU_SHELL(menu), mi, menu_position++);
+ }
++ enchant_dict_free_string_list(spell->speller, suggestions);
+ }
+
+- enchant_dict_free_suggestions(spell->speller, suggestions);
+-
+ /* + Add to Dictionary */
+ label = g_strdup_printf(_("Add \"%s\" to Dictionary"), word);
+ mi = gtk_image_menu_item_new_with_label(label);
diff --git a/app-text/gtkspell/gtkspell-2.0.15-r1.ebuild b/app-text/gtkspell/gtkspell-2.0.15-r1.ebuild
new file mode 100644
index 000000000000..f9b55604b053
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-2.0.15-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.15-r1.ebuild,v 1.1 2009/05/26 04:40:29 serkan Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Spell checking widget for GTK2"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+# gtkspell doesn't use sourceforge mirroring system it seems.
+SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=app-text/enchant-1.1.6"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ doc? ( >=dev-util/gtk-doc-1
+ =app-text/docbook-xml-dtd-4.2* )"
+
+src_prepare() {
+ # Bug #270177
+ epatch "${FILESDIR}"/${P}-fix-null-list.patch
+}
+
+src_configure() {
+ econf $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}