summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-23 16:36:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-23 16:36:42 +0000
commit2a908e3b64f8220ddc9d259415869e92bf46bc3c (patch)
tree246713d787abb000aae380d42cc909ee30a48020 /app-text/gv
parentBuild libXaw3d with --enable-internationalization by default in order to get ... (diff)
downloadgentoo-2-2a908e3b64f8220ddc9d259415869e92bf46bc3c.tar.gz
gentoo-2-2a908e3b64f8220ddc9d259415869e92bf46bc3c.tar.bz2
gentoo-2-2a908e3b64f8220ddc9d259415869e92bf46bc3c.zip
Enable the unicode codepath from libXaw3d wrt #372395 by Marco Paolone
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-text/gv')
-rw-r--r--app-text/gv/ChangeLog7
-rw-r--r--app-text/gv/gv-3.7.3-r1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index cd2bb90da8ce..706febf641fe 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/gv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.97 2012/01/22 19:46:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.98 2012/01/23 16:36:42 ssuominen Exp $
+
+*gv-3.7.3-r1 (23 Jan 2012)
+
+ 23 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +gv-3.7.3-r1.ebuild:
+ Enable the unicode codepath from libXaw3d wrt #372395 by Marco Paolone
22 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> -gv-3.7.1.ebuild,
-gv-3.7.2.ebuild:
diff --git a/app-text/gv/gv-3.7.3-r1.ebuild b/app-text/gv/gv-3.7.3-r1.ebuild
new file mode 100644
index 000000000000..72c6a3cc5715
--- /dev/null
+++ b/app-text/gv/gv-3.7.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.7.3-r1.ebuild,v 1.1 2012/01/23 16:36:42 ssuominen Exp $
+
+EAPI=4
+inherit eutils flag-o-matic
+
+DESCRIPTION="Viewer for PostScript and PDF documents using Ghostscript"
+HOMEPAGE="http://www.gnu.org/software/gv/"
+SRC_URI="mirror://gnu/gv/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+RDEPEND="app-text/ghostscript-gpl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXaw3d-1.6-r1
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.7.3-libXaw3d-1.6.patch
+}
+
+src_configure() {
+ # Expose the correct codepath from /usr/include/X11/Xaw3d/SimpleP.h
+ append-cppflags -DXAW_INTERNATIONALIZATION
+
+ export ac_cv_lib_Xinerama_main=$(usex xinerama)
+
+ econf \
+ --enable-scrollbar-code \
+ --enable-international
+}
+
+src_install() {
+ default
+
+ doicon "${FILESDIR}"/gv_icon.xpm
+ make_desktop_entry gv GhostView gv_icon "Graphics;Viewer"
+}