summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-01 04:30:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-01 04:30:01 +0000
commita95cba63759a4f733a208523dafd6425dc828f8c (patch)
treeb4dabffcf9877cd806e7fbec420fe030e9f834d1 /app-text/htag
parenttouchups (diff)
downloadgentoo-2-a95cba63759a4f733a208523dafd6425dc828f8c.tar.gz
gentoo-2-a95cba63759a4f733a208523dafd6425dc828f8c.tar.bz2
gentoo-2-a95cba63759a4f733a208523dafd6425dc828f8c.zip
touchups
Diffstat (limited to 'app-text/htag')
-rw-r--r--app-text/htag/htag-0.0.22.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/app-text/htag/htag-0.0.22.ebuild b/app-text/htag/htag-0.0.22.ebuild
index b398305c793a..0d075033dd0c 100644
--- a/app-text/htag/htag-0.0.22.ebuild
+++ b/app-text/htag/htag-0.0.22.ebuild
@@ -1,23 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htag/htag-0.0.22.ebuild,v 1.3 2003/02/13 09:38:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htag/htag-0.0.22.ebuild,v 1.4 2003/03/01 04:29:10 vapier Exp $
-S="${WORKDIR}/htag-${PV}"
-
-DESCRIPTION="HTag is a random signature maker for linux"
+DESCRIPTION="random signature maker"
HOMEPAGE="http://www.earth.li/projectpurple/progs/htag.html"
-SRC_URI="http://www.earth.li/projectpurple/files/htag-${PV}.tar.gz"
+SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.gz"
+
SLOT="0"
KEYWORDS="x86"
+LICENSE="GPL-2"
RDEPEND="sys-devel/perl"
-LICENSE="GPL-2"
-src_install () {
- mkdir -p $D/usr/{bin,lib/perl5/site_perl,share/htag/plugins,share/doc/htag-${PV},man/man1} || die
- install -o root -g root -m 755 htag.pl $D/usr/bin/htag || die
- cp -a docs/* $D/usr/share/doc/htag-${PV}/ || die
- find $D/usr/share/doc -type f ! -path '$D/usr/share/doc/htag-${PV}/sample-config/' | xargs gzip || die
- cp -a plugins/* $D/usr/share/htag/plugins/ || die
- install -o root -g root -m 644 HtagPlugin/HtagPlugin.pm $D/usr/lib/perl5/site_perl || die
+src_install() {
+ newbin htag.pl htag || die
+
+ dodir /usr/share/doc/${PF}/
+ mv docs/sample-config ${D}/usr/share/doc/${PF}/
+ dodoc docs/*
+ prepalldocs
+
+ insinto /usr/share/htag/plugins
+ doins plugins/* || die
+
+ insinto /usr/lib/perl5/site_perl
+ doins HtagPlugin/HtagPlugin.pm || die
}