summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-05-25 22:27:43 +0000
committerPeter Volkov <pva@gentoo.org>2009-05-25 22:27:43 +0000
commitf54445f0a961d6b57ba19983eb854eb3dd683ac7 (patch)
tree1ca0e7f5a113c65ed055c0cbb0cae052fe968bb5 /app-text/kchmviewer
parentdrop virtual/libc dep (diff)
downloadgentoo-2-f54445f0a961d6b57ba19983eb854eb3dd683ac7.tar.gz
gentoo-2-f54445f0a961d6b57ba19983eb854eb3dd683ac7.tar.bz2
gentoo-2-f54445f0a961d6b57ba19983eb854eb3dd683ac7.zip
Lot's of changes: EAPI-2, change slot to :3.5 (all 3.5 kde applications will have it), disable arts by default, use kde eclass, enable langs. Thank Theo Chatzimichos for this work. As a side work fixes bug #270576, thank Yar Odin for report.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-text/kchmviewer')
-rw-r--r--app-text/kchmviewer/ChangeLog10
-rw-r--r--app-text/kchmviewer/kchmviewer-3.1_p2-r1.ebuild57
2 files changed, 66 insertions, 1 deletions
diff --git a/app-text/kchmviewer/ChangeLog b/app-text/kchmviewer/ChangeLog
index 31fccc035fa5..deb42aaa262a 100644
--- a/app-text/kchmviewer/ChangeLog
+++ b/app-text/kchmviewer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/kchmviewer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kchmviewer/ChangeLog,v 1.12 2009/04/06 11:36:00 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kchmviewer/ChangeLog,v 1.13 2009/05/25 22:27:43 pva Exp $
+
+*kchmviewer-3.1_p2-r1 (25 May 2009)
+
+ 25 May 2009; Peter Volkov <pva@gentoo.org> +kchmviewer-3.1_p2-r1.ebuild:
+ Lot's of changes: EAPI-2, change slot to :3.5 (all 3.5 kde applications
+ will have it), disable arts by default, use kde eclass, enable langs.
+ Thank Theo Chatzimichos for this work. As a side work fixes bug #270576,
+ thank Yar Odin for report.
06 Apr 2009; Tomas Chvatal <scarabeus@gentoo.org>
kchmviewer-4.0-r1.ebuild:
diff --git a/app-text/kchmviewer/kchmviewer-3.1_p2-r1.ebuild b/app-text/kchmviewer/kchmviewer-3.1_p2-r1.ebuild
new file mode 100644
index 000000000000..1a5cc7a776fe
--- /dev/null
+++ b/app-text/kchmviewer/kchmviewer-3.1_p2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kchmviewer/kchmviewer-3.1_p2-r1.ebuild,v 1.1 2009/05/25 22:27:43 pva Exp $
+
+EAPI="2"
+
+ARTS_REQUIRED="never"
+
+LANGS="cs fr ru tr zh_CN"
+
+USE_KEG_PACKAGING="1"
+
+inherit kde versionator
+
+set-kdedir 3.5
+
+MY_P=${PN}-$(replace_version_separator 2 '-')
+MY_P=${MY_P/p}
+
+DESCRIPTION="KchmViewer is a feature rich chm file viewer, based on Qt."
+HOMEPAGE="http://www.kchmviewer.net/"
+SRC_URI="mirror://sourceforge/kchmviewer/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="3.5"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="kde"
+
+DEPEND="!<app-text/kchmviewer-3.1_p2-r1
+ x11-libs/qt:3
+ dev-libs/chmlib
+ kde? ( kde-base/kdelibs:3.5 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
+
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" ) #218812
+
+src_prepare() {
+ kde_src_prepare
+ # broken configure script, assure it doesn't fall back to internal libs
+ echo "# We use the external chmlib!" > lib/chmlib/chm_lib.h
+}
+
+src_install() {
+ kde_src_install
+
+ dodoc ChangeLog FAQ DCOP-bingings README || die "installing docs failed"
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/usr/share/services/chm.protocol ]]; then
+ ewarn "kchmviewer and kdevelop's kio_chm don't work together, bug #260134."
+ ewarn "Until we find better solution, if you want to read chm files with ${PN}"
+ ewarn "you need to remove ${ROOT}usr/share/services/chm.protocol file manually."
+ fi
+}