summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-12-27 15:33:33 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-12-27 15:33:33 +0000
commit29558e46d4733084000d5c64691959835182ea9c (patch)
tree180528226b975765f2eda0738a163d838dd63dcb /app-text/libetonyek
parentStable for HPPA (bug #494768). (diff)
downloadgentoo-2-29558e46d4733084000d5c64691959835182ea9c.tar.gz
gentoo-2-29558e46d4733084000d5c64691959835182ea9c.tar.bz2
gentoo-2-29558e46d4733084000d5c64691959835182ea9c.zip
Fix boost build wrt bug#496146
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-text/libetonyek')
-rw-r--r--app-text/libetonyek/ChangeLog7
-rw-r--r--app-text/libetonyek/files/libetonyek-0.0.3-comma.patch11
-rw-r--r--app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch56
-rw-r--r--app-text/libetonyek/libetonyek-0.0.3.ebuild7
4 files changed, 79 insertions, 2 deletions
diff --git a/app-text/libetonyek/ChangeLog b/app-text/libetonyek/ChangeLog
index 800c5985ac7e..617a10e54ac5 100644
--- a/app-text/libetonyek/ChangeLog
+++ b/app-text/libetonyek/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libetonyek
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/ChangeLog,v 1.2 2013/12/27 08:53:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/ChangeLog,v 1.3 2013/12/27 15:33:33 scarabeus Exp $
+
+ 27 Dec 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/libetonyek-0.0.3-comma.patch,
+ +files/libetonyek-0.0.3-lexical_cast.patch, libetonyek-0.0.3.ebuild:
+ Fix boost build wrt bug#496146
*libetonyek-0.0.3 (27 Dec 2013)
diff --git a/app-text/libetonyek/files/libetonyek-0.0.3-comma.patch b/app-text/libetonyek/files/libetonyek-0.0.3-comma.patch
new file mode 100644
index 000000000000..1504acc4c115
--- /dev/null
+++ b/app-text/libetonyek/files/libetonyek-0.0.3-comma.patch
@@ -0,0 +1,11 @@
+--- libetonyek-0.0.3/src/lib/KEYEnum.h 2013-12-06 09:40:36.000000000 +0100
++++ libetonyek-0.0.3/src/lib/KEYEnum.h 2013-12-15 06:21:26.372083749 +0100
+@@ -33,7 +33,7 @@
+ KEY_CAPITALIZATION_NONE,
+ KEY_CAPITALIZATION_ALL_CAPS,
+ KEY_CAPITALIZATION_SMALL_CAPS,
+- KEY_CAPITALIZATION_TITLE,
++ KEY_CAPITALIZATION_TITLE
+ };
+
+ }
diff --git a/app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch b/app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch
new file mode 100644
index 000000000000..19a5aead224d
--- /dev/null
+++ b/app-text/libetonyek/files/libetonyek-0.0.3-lexical_cast.patch
@@ -0,0 +1,56 @@
+--- libetonyek-0.0.3/src/lib/KEY2ParserUtils.cpp 2013-12-01 21:44:51.000000000 +0100
++++ libetonyek-0.0.3/src/lib/KEY2ParserUtils.cpp 2013-12-15 06:53:07.474721349 +0100
+@@ -125,7 +125,7 @@
+ return KEYSize(size.second, size.first);
+ }
+
+-bool KEY2ParserUtils::bool_cast(const char *const value)
++bool KEY2ParserUtils::bool_cast(const char *value)
+ {
+ KEY2Tokenizer tok;
+ switch (tok(value))
+@@ -142,6 +142,16 @@
+ return false;
+ }
+
++double KEY2ParserUtils::double_cast(const char *value)
++{
++ return lexical_cast<double, const char *>(value);
++}
++
++int KEY2ParserUtils::int_cast(const char *value)
++{
++ return lexical_cast<int, const char *>(value);
++}
++
+ double KEY2ParserUtils::deg2rad(double value)
+ {
+ // normalize range
+--- libetonyek-0.0.3/src/lib/KEY2ParserUtils.h 2013-10-30 22:04:38.000000000 +0100
++++ libetonyek-0.0.3/src/lib/KEY2ParserUtils.h 2013-12-15 06:50:40.296884951 +0100
+@@ -81,6 +81,8 @@
+ * @returns the boolean value of the string
+ */
+ static bool bool_cast(const char *value);
++ static double double_cast(const char *value);
++ static int int_cast(const char *value);
+
+ static double deg2rad(double value);
+
+--- libetonyek-0.0.3/src/lib/KEY2StyleParser.cpp 2013-12-06 10:36:13.000000000 +0100
++++ libetonyek-0.0.3/src/lib/KEY2StyleParser.cpp 2013-12-15 06:53:45.353451061 +0100
+@@ -62,12 +62,12 @@
+
+ optional<double> readDouble(const KEYXMLReader &reader)
+ {
+- return readNumber<double>(reader, KEY2Token::f, &lexical_cast<double, const char *>);
++ return readNumber<double>(reader, KEY2Token::f, &KEY2ParserUtils::double_cast);
+ }
+
+ optional<int> readInt(const KEYXMLReader &reader)
+ {
+- return readNumber<int>(reader, KEY2Token::i, &lexical_cast<int, const char *>);
++ return readNumber<int>(reader, KEY2Token::i, &KEY2ParserUtils::double_cast);
+ }
+
+ optional<KEYColor> readColor(const KEYXMLReader &reader)
diff --git a/app-text/libetonyek/libetonyek-0.0.3.ebuild b/app-text/libetonyek/libetonyek-0.0.3.ebuild
index 3b3e266f03a5..9948fc688d84 100644
--- a/app-text/libetonyek/libetonyek-0.0.3.ebuild
+++ b/app-text/libetonyek/libetonyek-0.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/libetonyek-0.0.3.ebuild,v 1.1 2013/12/27 08:53:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/libetonyek-0.0.3.ebuild,v 1.2 2013/12/27 15:33:33 scarabeus Exp $
EAPI=5
@@ -33,6 +33,11 @@ DEPEND="${RDEPEND}
test? ( dev-util/cppunit )
"
+PATCHES=(
+ "${FILESDIR}/${P}-comma.patch"
+ "${FILESDIR}/${P}-lexical_cast.patch"
+)
+
src_prepare() {
[[ -d m4 ]] || mkdir "m4"
base_src_prepare