summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2008-05-21 23:35:12 +0000
committerMike Pagano <mpagano@gentoo.org>2008-05-21 23:35:12 +0000
commit1d1773f714255849d542fda02cb214c082b4f290 (patch)
tree71ad5ff837be8b080b9116781c44b066d8433bf1 /app-text/man2html
parentamd64 stable, bug #223143 (diff)
downloadgentoo-2-1d1773f714255849d542fda02cb214c082b4f290.tar.gz
gentoo-2-1d1773f714255849d542fda02cb214c082b4f290.tar.bz2
gentoo-2-1d1773f714255849d542fda02cb214c082b4f290.zip
Version bump
(Portage version: 2.1.5.2)
Diffstat (limited to 'app-text/man2html')
-rw-r--r--app-text/man2html/ChangeLog10
-rw-r--r--app-text/man2html/files/mansec-1.6f.patch12
-rw-r--r--app-text/man2html/man2html-1.6f.ebuild56
3 files changed, 76 insertions, 2 deletions
diff --git a/app-text/man2html/ChangeLog b/app-text/man2html/ChangeLog
index f0aacfdb37eb..26933900e298 100644
--- a/app-text/man2html/ChangeLog
+++ b/app-text/man2html/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/man2html
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/ChangeLog,v 1.19 2007/09/01 12:38:24 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/ChangeLog,v 1.20 2008/05/21 23:35:12 mpagano Exp $
+
+*man2html-1.6f (21 May 2008)
+
+ 21 May 2008; Mike Pagano <mpagano@gentoo.org> +files/mansec-1.6f.patch,
+ +man2html-1.6f.ebuild:
+ Version bump. Added patch from bug #174730 tks to Ed Catmur
01 Sep 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing twp from metadata due to his retirement (see #190561 for reference).
diff --git a/app-text/man2html/files/mansec-1.6f.patch b/app-text/man2html/files/mansec-1.6f.patch
new file mode 100644
index 000000000000..82f0dd487d90
--- /dev/null
+++ b/app-text/man2html/files/mansec-1.6f.patch
@@ -0,0 +1,12 @@
+--- man2html/scripts/cgi-bin/man/mansec.orig 2008-05-21 10:03:36.000000000 -0400
++++ man2html/scripts/cgi-bin/man/mansec 2008-05-21 10:04:46.000000000 -0400
+@@ -117,7 +117,8 @@ BEGIN {
+ print "<p>Manual pages found under " man_path "." > cache_tmp;
+
+ # Find any man[1-8]/filenames
+- while ((("find " man_path " -follow -type f -printf '%f\n' | sort -f ") | getline manpage) > 0) {
++ find_cmd = "find " man_path " -follow -type f -printf '%f\n' | sort -f | uniq " ;
++ while ((find_cmd | getline manpage) > 0) {
+ # Check for new letter of alphabet
+ letter = tolower(substr(manpage,1,1));
+ if (letter != last_letter) {
diff --git a/app-text/man2html/man2html-1.6f.ebuild b/app-text/man2html/man2html-1.6f.ebuild
new file mode 100644
index 000000000000..dfb338c14755
--- /dev/null
+++ b/app-text/man2html/man2html-1.6f.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/man2html-1.6f.ebuild,v 1.1 2008/05/21 23:35:12 mpagano Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Convert manual pages to HTML"
+HOMEPAGE="http://freshmeat.net/projects/man/"
+SRC_URI="mirror://kernel/linux/utils/man/man-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-misc/glimpse
+ sys-apps/gawk
+ virtual/man"
+
+S=${WORKDIR}/man-${PV}
+
+pkg_setup() {
+ webapp_pkg_setup
+ einfo "Installing into ${MY_HOSTROOTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/mansearch-gentoo.patch
+ epatch "${FILESDIR}"/mansec-${PV}.patch
+ find man2html -type f | xargs sed -i \
+ -e "s:/home/httpd/htdocs/:/var/www/localhost/:g" \
+ -e "s:/home/httpd/cgi-bin/:/var/www/localhost/cgi-bin/man:g" \
+ -e "s:/home/httpd/cgi-aux/man:/var/www/localhost/cgi-aux/man:g"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd man2html
+ exeinto ${MY_HOSTROOTDIR}/cgi-bin/man
+ doexe scripts/cgi-bin/man/*
+ insinto ${MY_HOSTROOTDIR}/cgi-aux/man
+ doins scripts/cgi-aux/man/*
+ insinto /var/man2html
+ newins glimpse_filters .glimpse_filters
+ fperms 1777 /var/man2html
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man2html.cron man2html
+
+ webapp_src_install
+}