summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-05-24 15:19:11 +0000
committerPeter Volkov <pva@gentoo.org>2011-05-24 15:19:11 +0000
commit9ae3e3eda6f60067e745c27f8082c2c6ee4034ad (patch)
tree575da3385d23e2e772f18e924b28b4120228dd82 /app-text/mathtex
parentMarking curl-7.21.4 ppc for bug 355595 (diff)
downloadgentoo-2-9ae3e3eda6f60067e745c27f8082c2c6ee4034ad.tar.gz
gentoo-2-9ae3e3eda6f60067e745c27f8082c2c6ee4034ad.tar.bz2
gentoo-2-9ae3e3eda6f60067e745c27f8082c2c6ee4034ad.zip
Version bump. Add support to generate png images by default, bug #368471 thank Alexander Sulfrian for report.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mathtex')
-rw-r--r--app-text/mathtex/ChangeLog11
-rw-r--r--app-text/mathtex/mathtex-1.04.ebuild47
-rw-r--r--app-text/mathtex/metadata.xml3
3 files changed, 59 insertions, 2 deletions
diff --git a/app-text/mathtex/ChangeLog b/app-text/mathtex/ChangeLog
index 23d35bf55bf8..735cf4f261b1 100644
--- a/app-text/mathtex/ChangeLog
+++ b/app-text/mathtex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/mathtex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/ChangeLog,v 1.1 2009/12/21 20:34:57 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/ChangeLog,v 1.2 2011/05/24 15:19:11 pva Exp $
+
+*mathtex-1.04 (24 May 2011)
+
+ 24 May 2011; Peter Volkov <pva@gentoo.org> +mathtex-1.04.ebuild,
+ metadata.xml:
+ Version bump. Add support to generate png images by default, bug #368471
+ thank Alexander Sulfrian for report.
*mathtex-1.03 (21 Dec 2009)
diff --git a/app-text/mathtex/mathtex-1.04.ebuild b/app-text/mathtex/mathtex-1.04.ebuild
new file mode 100644
index 000000000000..9b39684c6cc5
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.04.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/mathtex-1.04.ebuild,v 1.1 2011/05/24 15:19:11 pva Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="MathTeX lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="http://www.forkosh.com/mathtex.html"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png"
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+DEPEND=""
+
+S=${WORKDIR}
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ $(use png && echo "-DPNG") \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex
+ dodoc README
+ dohtml mathtex.html
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}
diff --git a/app-text/mathtex/metadata.xml b/app-text/mathtex/metadata.xml
index ab1c52d05973..789145ed0aa9 100644
--- a/app-text/mathtex/metadata.xml
+++ b/app-text/mathtex/metadata.xml
@@ -6,6 +6,9 @@
<email>pva@gentoo.org</email>
<name>Peter Volkov</name>
</maintainer>
+<use>
+<flag name='png'>Generate png images by default instead of gif</flag>
+</use>
<longdescription>
MathTeX parses a LaTeX math expression and immediately emits the corresponding
gif (or png) image. It can be used as cgi program to embed LaTeX math in your