summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-05-31 12:01:24 +0000
committerNaohiro Aota <naota@gentoo.org>2012-05-31 12:01:24 +0000
commit1c2e917a189d027fe98638f36eaf1c43a5ee4699 (patch)
tree0b3c4a73fc3b541556f4077752e277c29ff0ce93 /app-text/mecab
parentVersion bump (bug #412083). (diff)
downloadgentoo-2-1c2e917a189d027fe98638f36eaf1c43a5ee4699.tar.gz
gentoo-2-1c2e917a189d027fe98638f36eaf1c43a5ee4699.tar.bz2
gentoo-2-1c2e917a189d027fe98638f36eaf1c43a5ee4699.zip
Version bumped. #411249
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/ChangeLog7
-rw-r--r--app-text/mecab/mecab-0.993.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-text/mecab/ChangeLog b/app-text/mecab/ChangeLog
index aca01a81331d..26d123c14426 100644
--- a/app-text/mecab/ChangeLog
+++ b/app-text/mecab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/mecab
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.69 2012/05/17 16:37:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.70 2012/05/31 12:01:24 naota Exp $
+
+*mecab-0.993 (31 May 2012)
+
+ 31 May 2012; Naohiro Aota <naota@gentoo.org> +mecab-0.993.ebuild:
+ Version bumped. #411249
17 May 2012; Alexis Ballier <aballier@gentoo.org> mecab-0.991.ebuild:
keyword ~amd64-fbsd
diff --git a/app-text/mecab/mecab-0.993.ebuild b/app-text/mecab/mecab-0.993.ebuild
new file mode 100644
index 000000000000..9a6bbf998468
--- /dev/null
+++ b/app-text/mecab/mecab-0.993.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.993.ebuild,v 1.1 2012/05/31 12:01:24 naota Exp $
+
+EAPI="4"
+inherit autotools eutils
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="http://mecab.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="static-libs unicode"
+
+DEPEND="dev-lang/perl
+ virtual/libiconv"
+RDEPEND=""
+PDEPEND="|| (
+ >=app-dicts/mecab-ipadic-2.7.0.20070610[unicode=]
+ app-dicts/mecab-naist-jdic[unicode=]
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+ epatch "${FILESDIR}/${PN}-0.98-iconv.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete
+ fi
+
+ dodoc AUTHORS README
+ dohtml -r doc/*
+}