summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-16 07:31:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-16 07:31:03 +0000
commite78bedac988fe434bddbe145970aae83cbe441e6 (patch)
treea0d2fd27c7ceae6e4554bbe855ce903102ab3d20 /app-text/mecab
parentBump (diff)
downloadgentoo-2-e78bedac988fe434bddbe145970aae83cbe441e6.tar.gz
gentoo-2-e78bedac988fe434bddbe145970aae83cbe441e6.tar.bz2
gentoo-2-e78bedac988fe434bddbe145970aae83cbe441e6.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/ChangeLog8
-rw-r--r--app-text/mecab/mecab-0.994.ebuild53
2 files changed, 59 insertions, 2 deletions
diff --git a/app-text/mecab/ChangeLog b/app-text/mecab/ChangeLog
index 26d123c14426..30a0532bb895 100644
--- a/app-text/mecab/ChangeLog
+++ b/app-text/mecab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/mecab
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.70 2012/05/31 12:01:24 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.71 2012/11/16 07:31:03 patrick Exp $
+
+*mecab-0.994 (16 Nov 2012)
+
+ 16 Nov 2012; Patrick Lauer <patrick@gentoo.org> +mecab-0.994.ebuild:
+ Bump
*mecab-0.993 (31 May 2012)
@@ -255,4 +260,3 @@
17 Aug 2003; MATSUU Takuto <matsuu@gentoo.org> mecab-0.76.ebuild:
initial import.
-
diff --git a/app-text/mecab/mecab-0.994.ebuild b/app-text/mecab/mecab-0.994.ebuild
new file mode 100644
index 000000000000..d88a5ff6b22c
--- /dev/null
+++ b/app-text/mecab/mecab-0.994.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.994.ebuild,v 1.1 2012/11/16 07:31:03 patrick Exp $
+
+EAPI="4"
+inherit autotools eutils
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="http://mecab.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="static-libs unicode"
+
+DEPEND="dev-lang/perl
+ virtual/libiconv"
+RDEPEND=""
+PDEPEND="|| (
+ >=app-dicts/mecab-ipadic-2.7.0.20070610[unicode=]
+ app-dicts/mecab-naist-jdic[unicode=]
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+ epatch "${FILESDIR}/${PN}-0.98-iconv.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete
+ fi
+
+ dodoc AUTHORS README
+ dohtml -r doc/*
+}