summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-30 12:03:38 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-30 12:03:38 +0000
commitbdc01d24cae1d1fafdbb9bd40a118496d678eb7d (patch)
treeec35e74a70f2336e8f1706662d8ea9cfb838fbfb /app-text/mupdf
parentRespecting LDFLAGS. Bug #335155 (diff)
downloadgentoo-2-bdc01d24cae1d1fafdbb9bd40a118496d678eb7d.tar.gz
gentoo-2-bdc01d24cae1d1fafdbb9bd40a118496d678eb7d.tar.bz2
gentoo-2-bdc01d24cae1d1fafdbb9bd40a118496d678eb7d.zip
version bump to 0.7
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mupdf')
-rw-r--r--app-text/mupdf/ChangeLog8
-rw-r--r--app-text/mupdf/files/mupdf-0.7-buildsystem.patch44
-rw-r--r--app-text/mupdf/mupdf-0.7.ebuild59
3 files changed, 110 insertions, 1 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index a0674da73a50..ff22f048f604 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.1 2010/08/24 23:08:44 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.2 2010/08/30 12:03:38 xmw Exp $
+
+*mupdf-0.7 (30 Aug 2010)
+
+ 30 Aug 2010; Michael Weber (xmw) <xmw@gentoo.org> +mupdf-0.7.ebuild,
+ +files/mupdf-0.7-buildsystem.patch:
+ Version bump, buildsystem still needs a patch for CC and LDFLAGS
*mupdf-0.6 (24 Aug 2010)
diff --git a/app-text/mupdf/files/mupdf-0.7-buildsystem.patch b/app-text/mupdf/files/mupdf-0.7-buildsystem.patch
new file mode 100644
index 000000000000..003e22a37e32
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-0.7-buildsystem.patch
@@ -0,0 +1,44 @@
+--- Makefile.orig 2010-08-30 13:49:42.022000015 +0200
++++ Makefile 2010-08-30 13:51:30.274000015 +0200
+@@ -6,7 +6,8 @@
+ default: all
+
+ build ?= debug
+-prefix ?= /usr/local
++prefix ?= /usr
++libprefix ?= $(prefix)/lib
+
+ OBJDIR := build/$(build)
+ GENDIR := build/generated
+@@ -378,7 +379,7 @@
+ rm -rf build
+
+ install: $(OBJDIR) $(GENDIR) $(MUPDF_LIB) $(APPS)
+- install -d $(prefix)/bin $(prefix)/lib $(prefix)/include
++ install -d $(prefix)/bin $(libprefix) $(prefix)/include
+ install $(APPS) $(prefix)/bin
+- install $(MUPDF_LIB) $(prefix)/lib
++ install $(MUPDF_LIB) $(libprefix)
+ install $(MUPDF_HDR) $(prefix)/include
+--- Makerules.orig 2010-08-30 13:52:12.870000016 +0200
++++ Makerules 2010-08-30 13:54:08.731000014 +0200
+@@ -4,8 +4,8 @@
+ OS := $(OS:MINGW%=MINGW)
+
+ CC ?= cc
+-CFLAGS := -Ifitz -Imupdf -Wall
+-LDFLAGS :=
++CFLAGS += -Ifitz -Imupdf
++LDFLAGS +=
+
+ ifeq "$(build)" "debug"
+ CFLAGS += -pipe -g
+@@ -21,7 +21,7 @@
+
+ ifeq "$(OS)" "Linux"
+ SYS_FREETYPE_INC := `pkg-config --cflags freetype2`
+-X11LIBS := -lX11 -lXext
++X11LIBS := `pkg-config --libs x11 xext`
+ PDFVIEW_EXE = $(X11VIEW_EXE)
+ endif
+
diff --git a/app-text/mupdf/mupdf-0.7.ebuild b/app-text/mupdf/mupdf-0.7.ebuild
new file mode 100644
index 000000000000..ee1f78f0267e
--- /dev/null
+++ b/app-text/mupdf/mupdf-0.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-0.7.ebuild,v 1.1 2010/08/30 12:03:38 xmw Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="http://mupdf.com/"
+SRC_URI="http://${PN}.com/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="media-libs/freetype:2
+ media-libs/jbig2dec
+ media-libs/jpeg
+ media-libs/openjpeg
+ X? ( x11-libs/libX11
+ x11-libs/libXext )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+}
+
+src_compile() {
+ my_pdfexe=
+ use X || my_pdfexe="PDFVIEW_EXE="
+
+ emake build=release ${my_pdfexe} CC="$(tc-getCC)" verbose=true || die
+}
+
+src_install() {
+ emake build=release ${my_pdfexe} prefix="${D}usr" \
+ libprefix="${D}usr/$(get_libdir)" verbose=true install || die
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins debian/mupdf.pc || die
+
+ if use X ; then
+ domenu debian/mupdf.desktop || die
+ doicon debian/mupdf.xpm || die
+ doman debian/mupdf.1 || die
+ fi
+ doman debian/pdf{clean,draw,show}.1 || die
+ dodoc README || die
+
+ # avoid collision with app-text/poppler-utils
+ mv "${D}"usr/bin/pdfinfo "${D}"usr/bin/mupdf_pdfinfo || die
+}
+
+pkg_postinst() {
+ elog "pdfinfo was renamed to mupdf_pdfinfo"
+}