summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-07 15:13:41 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-07 15:13:41 +0000
commitdeb9ac85498211622faf08b2e8205fc195491b56 (patch)
treecc1e7e108aaa73638b742f961092a6d0502a9ef3 /app-text/pastebin
parenthttp://my.opera.com/desktopteam/blog/2011/10/07/ragnarok-css3-radial-gradients (diff)
downloadgentoo-2-deb9ac85498211622faf08b2e8205fc195491b56.tar.gz
gentoo-2-deb9ac85498211622faf08b2e8205fc195491b56.tar.bz2
gentoo-2-deb9ac85498211622faf08b2e8205fc195491b56.zip
Fix warning on unassigned variable, #384769; thanks Micheal for the patch
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'app-text/pastebin')
-rw-r--r--app-text/pastebin/ChangeLog8
-rw-r--r--app-text/pastebin/files/0.6.2-lnot-specified.patch16
-rw-r--r--app-text/pastebin/metadata.xml2
-rw-r--r--app-text/pastebin/pastebin-0.6.2-r1.ebuild29
4 files changed, 53 insertions, 2 deletions
diff --git a/app-text/pastebin/ChangeLog b/app-text/pastebin/ChangeLog
index 73badbcc1399..3b3c342fe099 100644
--- a/app-text/pastebin/ChangeLog
+++ b/app-text/pastebin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pastebin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pastebin/ChangeLog,v 1.11 2011/01/12 07:29:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pastebin/ChangeLog,v 1.12 2011/10/07 15:13:41 jlec Exp $
+
+*pastebin-0.6.2-r1 (07 Oct 2011)
+
+ 07 Oct 2011; Justin Lecher <jlec@gentoo.org>
+ +files/0.6.2-lnot-specified.patch, +pastebin-0.6.2-r1.ebuild, metadata.xml:
+ Fix warning on unassigned variable, #384769; thanks Micheal for the patch
12 Jan 2011; Justin Lecher <jlec@gentoo.org> -pastebin-0.6.1.ebuild:
Removed old
diff --git a/app-text/pastebin/files/0.6.2-lnot-specified.patch b/app-text/pastebin/files/0.6.2-lnot-specified.patch
new file mode 100644
index 000000000000..047068de8857
--- /dev/null
+++ b/app-text/pastebin/files/0.6.2-lnot-specified.patch
@@ -0,0 +1,16 @@
+ pastebin | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/pastebin b/pastebin
+index 1e4c65c..c2aaa2d 100755
+--- a/pastebin
++++ b/pastebin
+@@ -224,7 +224,7 @@ sub name {
+ }
+
+ sub language {
+- my $lang = lc $options->{l} || return 'text';
++ my $lang = defined $options->{l} ? lc $options->{l} : return 'text';
+
+ for my $language (keys %languages) {
+ my $check = Other::escape($languages{$language});
diff --git a/app-text/pastebin/metadata.xml b/app-text/pastebin/metadata.xml
index 80ac69d9c2f2..40149c995561 100644
--- a/app-text/pastebin/metadata.xml
+++ b/app-text/pastebin/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>shell-tools</herd>
+ <herd>shell-tools</herd>
</pkgmetadata>
diff --git a/app-text/pastebin/pastebin-0.6.2-r1.ebuild b/app-text/pastebin/pastebin-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..c2a941b8e38e
--- /dev/null
+++ b/app-text/pastebin/pastebin-0.6.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pastebin/pastebin-0.6.2-r1.ebuild,v 1.1 2011/10/07 15:13:41 jlec Exp $
+
+EAPI=4
+
+inherit eutils perl-app
+
+DESCRIPTION="CLI to pastebin.com"
+HOMEPAGE="http://code.google.com/p/pastebin-cli/"
+SRC_URI="http://pastebin-cli.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-perl/libwww-perl"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-lnot-specified.patch
+}
+
+src_install() {
+ dobin ${PN}
+}