summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-08-03 19:48:49 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-08-03 19:48:49 +0000
commit0ed3170ac1759c94d36a10a59407613d16b91044 (patch)
treecae165ccdabc7360fd8b7dc932805f993c4f680b /app-text/poppler-bindings
parentremove hal from RDEPEND since it's not used (diff)
downloadgentoo-2-0ed3170ac1759c94d36a10a59407613d16b91044.tar.gz
gentoo-2-0ed3170ac1759c94d36a10a59407613d16b91044.tar.bz2
gentoo-2-0ed3170ac1759c94d36a10a59407613d16b91044.zip
Bump. Fixes for memory leaks, feature additions.
(Portage version: 2.2_rc6/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'app-text/poppler-bindings')
-rw-r--r--app-text/poppler-bindings/ChangeLog8
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.8.4.ebuild5
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild82
3 files changed, 91 insertions, 4 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index 6640cfe3093c..4c25862a0a98 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.96 2008/07/07 15:58:18 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.97 2008/08/03 19:48:49 loki_val Exp $
+
+*poppler-bindings-0.8.5 (03 Aug 2008)
+
+ 03 Aug 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +poppler-bindings-0.8.5.ebuild:
+ Bump. Fixes for memory leaks, feature additions.
07 Jul 2008; Daniel Gryniewicz <dang@gentoo.org>
-poppler-bindings-0.8.3.ebuild:
diff --git a/app-text/poppler-bindings/poppler-bindings-0.8.4.ebuild b/app-text/poppler-bindings/poppler-bindings-0.8.4.ebuild
index 21c0f039b6f3..4be8dea675c0 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.8.4.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.4.ebuild,v 1.1 2008/06/29 11:08:40 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.4.ebuild,v 1.2 2008/08/03 19:48:49 loki_val Exp $
EAPI="1"
@@ -57,8 +57,7 @@ src_compile() {
export QTLIB="${QTDIR}/$(get_libdir)"
echo $QTLIB
- econf --enable-opi \
- $(use_enable cairo cairo-output) \
+ econf $(use_enable cairo cairo-output) \
$(use_enable gtk poppler-glib) \
$(use_enable qt3 poppler-qt) \
$(use_enable qt4 poppler-qt4) \
diff --git a/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild b/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild
new file mode 100644
index 000000000000..2caf7c05a27a
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild,v 1.1 2008/08/03 19:48:49 loki_val Exp $
+
+EAPI="1"
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org/"
+
+# Creating the testsuite tarball (must be done for every release)
+#
+# git clone git://anongit.freedesktop.org/git/poppler/test
+# rm -rf test/.git
+# tar czf poppler-test-${PV}.tar.gz test
+# upload to d.g.o/space/distfiles-local
+
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz
+ test? ( mirror://gentoo/poppler-test-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt3 cairo qt4 test"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? ( >=x11-libs/cairo-1.4 )
+ gtk? (
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/libglade-2
+ )
+ qt3? ( =x11-libs/qt-3* )
+ qt4? ( || ( ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4 )
+ =x11-libs/qt-4.3*:4 ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+
+ AT_M4DIR="m4" eautoreconf
+ cd poppler
+ ln -s /usr/lib/libpoppler.la
+}
+
+src_compile() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf $(use_enable cairo cairo-output) \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt3 poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ || die "configuration failed"
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}