summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-21 16:32:02 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-21 16:32:02 +0000
commit4934e042e692a13bc76e3a3c42dfe871f10c8274 (patch)
treee3646148d0d8e9806de3835c3da358db902efc28 /app-text/sablotron
parentNew patched version (fixes buffer overflow, plus other things). (diff)
downloadgentoo-2-4934e042e692a13bc76e3a3c42dfe871f10c8274.tar.gz
gentoo-2-4934e042e692a13bc76e3a3c42dfe871f10c8274.tar.bz2
gentoo-2-4934e042e692a13bc76e3a3c42dfe871f10c8274.zip
New Version
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/files/digest-sablotron-0.601
-rw-r--r--app-text/sablotron/sablotron-0.60.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-text/sablotron/files/digest-sablotron-0.60 b/app-text/sablotron/files/digest-sablotron-0.60
new file mode 100644
index 000000000000..b378d8102281
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-0.60
@@ -0,0 +1 @@
+MD5 2938b6c301355f832eb0f6be98f12570 Sablot-0.60.tar.gz
diff --git a/app-text/sablotron/sablotron-0.60.ebuild b/app-text/sablotron/sablotron-0.60.ebuild
new file mode 100644
index 000000000000..30eb06bfe36b
--- /dev/null
+++ b/app-text/sablotron/sablotron-0.60.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.60.ebuild,v 1.1 2001/06/21 16:32:02 achim Exp $
+
+A="Sablot-${PV}.tar.gz"
+S=${WORKDIR}/Sablot-${PV}
+DESCRIPTION="An XSLT Parser in C++"
+SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${A}"
+HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
+
+DEPEND=">=sys-devel/gcc-2.95.2 >=dev-libs/expat-1.95.1 virtual/glibc"
+
+
+src_compile() {
+ try ./configure --prefix=/usr --host=${CHOST}
+ try pmake
+
+}
+
+src_install () {
+ dodir /usr/lib
+ dodir /usr/include
+ dodir /usr/bin
+ try make prefix=${D}/usr install
+ dodoc README RELEASE
+ dodoc Sablot/TODO
+}
+
+
+