summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-11-26 15:04:24 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-11-26 15:04:24 +0000
commit8743da537df39262d2862168402e44ffd6e68ec2 (patch)
tree6deb28224ce1e4750cf891cd1332f523bc1605c7 /app-text/sablotron
parentfixes bugs, see ChangeLog (diff)
downloadgentoo-2-8743da537df39262d2862168402e44ffd6e68ec2.tar.gz
gentoo-2-8743da537df39262d2862168402e44ffd6e68ec2.tar.bz2
gentoo-2-8743da537df39262d2862168402e44ffd6e68ec2.zip
upgrade, hopefully fixes bug 11085
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/ChangeLog8
-rw-r--r--app-text/sablotron/files/digest-sablotron-0.961
-rw-r--r--app-text/sablotron/sablotron-0.96.ebuild40
3 files changed, 48 insertions, 1 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index faf81ad1b8c1..13d26a8a7a5d 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/sablotron
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.6 2002/09/24 05:30:47 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.7 2002/11/26 15:04:24 mcummings Exp $
+
+*sablotron-0.96 (26 Nov 2002)
+
+ 26 Nov 2002; Michael Cummings <mcummings@gentoo.org> sablotron-0.96.ebuild:
+
+ new version, masked for testing, seeing if it resolves bug 11085
*sablotron-0.95-r1 (13 Jul 2002)
diff --git a/app-text/sablotron/files/digest-sablotron-0.96 b/app-text/sablotron/files/digest-sablotron-0.96
new file mode 100644
index 000000000000..dc0d4c749847
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-0.96
@@ -0,0 +1 @@
+MD5 faa64d8005e5bf8328faf85466d096e1 Sablot-0.96.tar.gz 399961
diff --git a/app-text/sablotron/sablotron-0.96.ebuild b/app-text/sablotron/sablotron-0.96.ebuild
new file mode 100644
index 000000000000..e60f2246f858
--- /dev/null
+++ b/app-text/sablotron/sablotron-0.96.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.96.ebuild,v 1.1 2002/11/26 15:04:24 mcummings Exp $
+
+MY_P="Sablot-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An XSLT Parser in C++"
+SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
+
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~sparc ~sparc64"
+
+DEPEND=">=dev-libs/expat-1.95.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src/engine
+}
+
+src_compile() {
+
+ local myconf
+
+ use perl && myconf="--enable-perlconnect"
+
+ # rphillips
+ # fixes bug #3876
+ export LDFLAGS="-lstdc++"
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install () {
+ einstall || die
+ dodoc README* RELEASE
+ dodoc src/TODO
+}