summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-02 18:36:05 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-02 18:36:05 +0000
commitb9afc25e0ca63d5eb287518d5e9195ed04eec2d8 (patch)
tree8c02ad9c9dc1c32d799e5860ee6e58fc876f9d58 /app-text/wv
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-b9afc25e0ca63d5eb287518d5e9195ed04eec2d8.tar.gz
gentoo-2-b9afc25e0ca63d5eb287518d5e9195ed04eec2d8.tar.bz2
gentoo-2-b9afc25e0ca63d5eb287518d5e9195ed04eec2d8.zip
Build and install tools only when requested since they are considered deprecated in favor of using AbiWord, this also allows us to not depend on latex always.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-text/wv')
-rw-r--r--app-text/wv/ChangeLog10
-rw-r--r--app-text/wv/metadata.xml3
-rw-r--r--app-text/wv/wv-1.2.9-r1.ebuild59
3 files changed, 70 insertions, 2 deletions
diff --git a/app-text/wv/ChangeLog b/app-text/wv/ChangeLog
index 534e0d0b0aa0..114430e904a3 100644
--- a/app-text/wv/ChangeLog
+++ b/app-text/wv/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/wv
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.55 2011/01/31 14:00:53 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.56 2011/02/02 18:36:05 pacho Exp $
+
+*wv-1.2.9-r1 (02 Feb 2011)
+
+ 02 Feb 2011; Pacho Ramos <pacho@gentoo.org> +wv-1.2.9-r1.ebuild,
+ metadata.xml:
+ Build and install tools only when requested since they are considered
+ deprecated in favor of using AbiWord, this also allows us to not depend on
+ latex always.
31 Jan 2011; Pacho Ramos <pacho@gentoo.org> wv-1.2.9.ebuild:
ebuild cleanups by Gilles.
diff --git a/app-text/wv/metadata.xml b/app-text/wv/metadata.xml
index dad9001338dc..cebb8ad815ae 100644
--- a/app-text/wv/metadata.xml
+++ b/app-text/wv/metadata.xml
@@ -1,5 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>gnome</herd>
+<herd>gnome</herd>
+<use><flag name="tools">Install optional utilities considered deprecated in favor of using AbiWord.</flag></use>
</pkgmetadata>
diff --git a/app-text/wv/wv-1.2.9-r1.ebuild b/app-text/wv/wv-1.2.9-r1.ebuild
new file mode 100644
index 000000000000..3c52e1c050e2
--- /dev/null
+++ b/app-text/wv/wv-1.2.9-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/wv-1.2.9-r1.ebuild,v 1.1 2011/02/02 18:36:05 pacho Exp $
+
+EAPI="3"
+
+inherit eutils autotools
+
+DESCRIPTION="Tool for conversion of MSWord doc and rtf files to something readable"
+SRC_URI="http://abiword.org/downloads/${PN}/${PV}/${P}.tar.gz"
+HOMEPAGE="http://wvware.sourceforge.net/"
+
+IUSE="tools wmf"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-extra/libgsf-1.13
+ sys-libs/zlib
+ media-libs/libpng
+ dev-libs/libxml2
+ tools? ( app-text/texlive-core
+ dev-texlive/texlive-latex )
+ wmf? ( >=media-libs/libwmf-0.2.2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_prepare() {
+ if ! use tools; then
+ sed -i -e '/bin_/d' GNUmakefile.am || die
+ sed -i -e '/SUBDIRS/d' GNUmakefile.am || die
+ sed -i -e '/\/GNUmakefile/d' configure.ac || die
+ sed -i -e '/wv[A-Z]/d' configure.ac || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf $(use_with wmf libwmf)
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libwv-1.2.so.3
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libwv-1.2.so.3
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc README NEWS || die
+
+ rm -f "${ED}"/usr/share/man/man1/wvConvert.1
+ if use tools; then
+ dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1 || die
+ fi
+}