summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-02-19 15:09:59 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-02-19 15:09:59 +0000
commitcb42a5345b5ea326b6923d1a980af1edd7b2db6b (patch)
tree93691c2f50e519a665e7b5341ffa0eff69335264 /app-text/wv
parentSparc stable, part of Bug #199853. (diff)
downloadgentoo-2-cb42a5345b5ea326b6923d1a980af1edd7b2db6b.tar.gz
gentoo-2-cb42a5345b5ea326b6923d1a980af1edd7b2db6b.tar.bz2
gentoo-2-cb42a5345b5ea326b6923d1a980af1edd7b2db6b.zip
Version bump
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-text/wv')
-rw-r--r--app-text/wv/ChangeLog10
-rw-r--r--app-text/wv/wv-1.2.3-r1.ebuild6
-rw-r--r--app-text/wv/wv-1.2.4.ebuild50
3 files changed, 61 insertions, 5 deletions
diff --git a/app-text/wv/ChangeLog b/app-text/wv/ChangeLog
index b9e16be76a99..81a72341a1fa 100644
--- a/app-text/wv/ChangeLog
+++ b/app-text/wv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/wv
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.51 2007/12/25 13:13:54 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.52 2008/02/19 15:09:59 caleb Exp $
+
+*wv-1.2.4 (19 Feb 2008)
+
+ 19 Feb 2008; Caleb Tennis <caleb@gentoo.org> wv-1.2.3-r1.ebuild,
+ +wv-1.2.4.ebuild:
+ version bump
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing foser from metadata.xml as per #120234.
diff --git a/app-text/wv/wv-1.2.3-r1.ebuild b/app-text/wv/wv-1.2.3-r1.ebuild
index 8472a0652d02..c04d6c3d420c 100644
--- a/app-text/wv/wv-1.2.3-r1.ebuild
+++ b/app-text/wv/wv-1.2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wv/wv-1.2.3-r1.ebuild,v 1.10 2007/07/12 04:37:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/wv-1.2.3-r1.ebuild,v 1.11 2008/02/19 15:09:59 caleb Exp $
inherit eutils
@@ -37,7 +37,7 @@ src_install () {
dodoc README
- rm -f ${D}/usr/share/man/man1/wvConvert.1
+ rm -f "${D}"/usr/share/man/man1/wvConvert.1
dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1
}
diff --git a/app-text/wv/wv-1.2.4.ebuild b/app-text/wv/wv-1.2.4.ebuild
new file mode 100644
index 000000000000..d37e4303ca97
--- /dev/null
+++ b/app-text/wv/wv-1.2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/wv-1.2.4.ebuild,v 1.1 2008/02/19 15:09:59 caleb Exp $
+
+inherit eutils
+
+DESCRIPTION="Tool for conversion of MSWord doc and rtf files to something readable"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.gz"
+HOMEPAGE="http://wvware.sourceforge.net/"
+
+IUSE="wmf"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-extra/libgsf-1.13
+ sys-libs/zlib
+ media-libs/libpng
+ dev-libs/libxml2
+ wmf? ( >=media-libs/libwmf-0.2.2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_compile() {
+
+ econf `use_with wmf libwmf` || die "./configure failed"
+
+ emake || die "Compilation failed"
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README
+
+ rm -f "${D}"/usr/share/man/man1/wvConvert.1
+ dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1
+
+}
+
+pkg_postinst() {
+
+ ewarn "You have to re-emerge packages that linked against wv by running:"
+ ewarn "revdep-rebuild"
+
+}