summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-03-22 07:37:22 +0000
committerMamoru Komachi <usata@gentoo.org>2005-03-22 07:37:22 +0000
commit1585fcb01fe232d455db30ea92dfcd60f69e9dba (patch)
tree50ca22f90d52abab5e80b17fc30982e58d20603e /app-text/xmlstarlet/xmlstarlet-1.0.1.ebuild
parentVersion bump. This release fixes security hole, bug #85380 (diff)
downloadgentoo-2-1585fcb01fe232d455db30ea92dfcd60f69e9dba.tar.gz
gentoo-2-1585fcb01fe232d455db30ea92dfcd60f69e9dba.tar.bz2
gentoo-2-1585fcb01fe232d455db30ea92dfcd60f69e9dba.zip
Version bumped.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-text/xmlstarlet/xmlstarlet-1.0.1.ebuild')
-rw-r--r--app-text/xmlstarlet/xmlstarlet-1.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/xmlstarlet/xmlstarlet-1.0.1.ebuild b/app-text/xmlstarlet/xmlstarlet-1.0.1.ebuild
new file mode 100644
index 000000000000..fd4d7adfc41a
--- /dev/null
+++ b/app-text/xmlstarlet/xmlstarlet-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/xmlstarlet-1.0.1.ebuild,v 1.1 2005/03/22 07:37:22 usata Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="XMLStarlet is a set of XML command line utilities"
+HOMEPAGE="http://xmlstar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xmlstar/${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+DEPEND=">=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.9
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error"
+
+src_compile() {
+ append-ldflags -lgcrypt
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml -r *
+}
+
+src_test() {
+ cd tests
+ sh runTests || die "sh runTests failed."
+}