summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-02 10:37:26 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-02 10:37:26 +0000
commit375949fe27a67b9e2e1434f5498052fe148c6027 (patch)
tree99e2c0f2f07e522b6ccfcf67014c271c3aaa39b2 /app-text
parentCleanup old. (diff)
downloadgentoo-2-375949fe27a67b9e2e1434f5498052fe148c6027.tar.gz
gentoo-2-375949fe27a67b9e2e1434f5498052fe148c6027.tar.bz2
gentoo-2-375949fe27a67b9e2e1434f5498052fe148c6027.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/an/ChangeLog7
-rw-r--r--app-text/an/an-1.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-text/an/ChangeLog b/app-text/an/ChangeLog
index 93518fdb7acd..40bef7341cd2 100644
--- a/app-text/an/ChangeLog
+++ b/app-text/an/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/an
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.44 2014/03/02 17:28:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/ChangeLog,v 1.45 2014/07/02 10:37:26 jer Exp $
+
+*an-1.2 (02 Jul 2014)
+
+ 02 Jul 2014; Jeroen Roovers <jer@gentoo.org> +an-1.2.ebuild:
+ Version bump.
02 Mar 2014; Jeroen Roovers <jer@gentoo.org> an-1.1.ebuild:
Add dev-libs/icu sub-SLOT dependency (bug #455900).
diff --git a/app-text/an/an-1.2.ebuild b/app-text/an/an-1.2.ebuild
new file mode 100644
index 000000000000..3cc027bda424
--- /dev/null
+++ b/app-text/an/an-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/an/an-1.2.ebuild,v 1.1 2014/07/02 10:37:26 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast anagram generator with dictionary lookup"
+HOMEPAGE="http://packages.debian.org/unstable/games/an"
+
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-libs/icu:=
+"
+DEPEND="
+ app-arch/xz-utils
+"
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/miscfiles[-minimal]
+"
+
+src_prepare() {
+ sed -i \
+ -e '/^CC/s|:=|?=|' \
+ -e 's|$(CC) $(CFLAGS)|& $(LDFLAGS)|g' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.6 ${PN}.1
+ dodoc ALGORITHM
+}