summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-08 17:09:10 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-08 17:09:10 +0000
commit80946e7e225b2351fc1cecec7dd9e17c00b5f850 (patch)
tree6dbe441adfa877158ff22b745fbd6cec68b68c47 /app-text
parentKDbg is a graphical user interface to gdb, the GNU debugger. (diff)
downloadgentoo-2-80946e7e225b2351fc1cecec7dd9e17c00b5f850.tar.gz
gentoo-2-80946e7e225b2351fc1cecec7dd9e17c00b5f850.tar.bz2
gentoo-2-80946e7e225b2351fc1cecec7dd9e17c00b5f850.zip
*** empty log message ***
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ispell/files/digest-ispell-3.1.201
-rw-r--r--app-text/ispell/files/ispell-3.1.20.diff.gzbin0 -> 14325 bytes
-rw-r--r--app-text/ispell/ispell-3.1.20.ebuild45
3 files changed, 46 insertions, 0 deletions
diff --git a/app-text/ispell/files/digest-ispell-3.1.20 b/app-text/ispell/files/digest-ispell-3.1.20
new file mode 100644
index 000000000000..40dfce116c6b
--- /dev/null
+++ b/app-text/ispell/files/digest-ispell-3.1.20
@@ -0,0 +1 @@
+MD5 92986f940548fe4116428d21b16fd356 ispell-3.1.20.tar.gz
diff --git a/app-text/ispell/files/ispell-3.1.20.diff.gz b/app-text/ispell/files/ispell-3.1.20.diff.gz
new file mode 100644
index 000000000000..4542522120e9
--- /dev/null
+++ b/app-text/ispell/files/ispell-3.1.20.diff.gz
Binary files differ
diff --git a/app-text/ispell/ispell-3.1.20.ebuild b/app-text/ispell/ispell-3.1.20.ebuild
new file mode 100644
index 000000000000..ce6b2b6904f9
--- /dev/null
+++ b/app-text/ispell/ispell-3.1.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.1.20.ebuild,v 1.1 2001/02/08 17:09:10 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${PN}-3.1
+DESCRIPTION="Ispell is a fast screen-oriented spelling checker"
+SRC_URI="ftp://ftp.cs.ucla.edu/pub/ispell-3.1/${A}"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ gzip -dc ${FILESDIR}/${P}.diff.gz | patch -p1
+
+}
+
+src_compile() {
+
+ export PATH=$PATH:$PWD
+ try make -f Makefile.Linux compile
+
+}
+
+src_install () {
+
+ dobin buildhash findaffix icombine ijoin ispell \
+ munchlist sq tryaffix unsq
+
+ doman *.[1-5]
+ doinfo *.info
+
+ insinto /usr/share/emacs/site-lisp
+ doins ispell.el suse/*.el suse/emacs/*.el
+
+ insinto /usr/lib/ispell
+ doins languages/{american,british}/*.hash
+ doins languages/english/english.aff
+
+ dodoc Contributors README WISHES
+
+}
+