summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-04 09:20:50 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-04 09:20:50 +0000
commit9c94ebb360a8682fbfbaaace8df8cacec768b3e9 (patch)
tree874d39815074d49b68f24f8c3fb6871992937efa /app-text
parentbump; test phase added with exclusions made for unviable tests in the suite, ... (diff)
downloadgentoo-2-9c94ebb360a8682fbfbaaace8df8cacec768b3e9.tar.gz
gentoo-2-9c94ebb360a8682fbfbaaace8df8cacec768b3e9.tar.bz2
gentoo-2-9c94ebb360a8682fbfbaaace8df8cacec768b3e9.zip
Version bump. Bug #538754.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libodfgen/ChangeLog9
-rw-r--r--app-text/libodfgen/libodfgen-0.1.3.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-text/libodfgen/ChangeLog b/app-text/libodfgen/ChangeLog
index bef2086ff578..66eb98cf812c 100644
--- a/app-text/libodfgen/ChangeLog
+++ b/app-text/libodfgen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libodfgen
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.16 2014/12/30 15:07:14 dilfridge Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.17 2015/02/04 09:20:50 mgorny Exp $
+
+*libodfgen-0.1.3 (04 Feb 2015)
+
+ 04 Feb 2015; Michał Górny <mgorny@gentoo.org> +libodfgen-0.1.3.ebuild:
+ Version bump. Bug #538754.
30 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org>
libodfgen-0.0.4.ebuild:
diff --git a/app-text/libodfgen/libodfgen-0.1.3.ebuild b/app-text/libodfgen/libodfgen-0.1.3.ebuild
new file mode 100644
index 000000000000..9d93f3437610
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-0.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/libodfgen-0.1.3.ebuild,v 1.1 2015/02/04 09:20:50 mgorny Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+# git://git.code.sf.net/p/libwpd/libodfgen
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}