summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-06 00:11:46 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-06 00:11:46 +0000
commitb0f5ca3644aceafdb95a771f16cf239319253bec (patch)
tree3a6064d3d97489ef13e256a28564a24ce6c1e1c4 /app-text
parentVersion bump, remove old (diff)
downloadgentoo-2-b0f5ca3644aceafdb95a771f16cf239319253bec.tar.gz
gentoo-2-b0f5ca3644aceafdb95a771f16cf239319253bec.tar.bz2
gentoo-2-b0f5ca3644aceafdb95a771f16cf239319253bec.zip
add prefix changes
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rfcutil/ChangeLog8
-rw-r--r--app-text/rfcutil/files/rfc-3.2.3-paths.patch22
-rw-r--r--app-text/rfcutil/rfcutil-3.2.3-r2.ebuild46
3 files changed, 75 insertions, 1 deletions
diff --git a/app-text/rfcutil/ChangeLog b/app-text/rfcutil/ChangeLog
index 867f574a88f3..7e70d9a241fe 100644
--- a/app-text/rfcutil/ChangeLog
+++ b/app-text/rfcutil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/rfcutil
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/ChangeLog,v 1.33 2012/05/10 15:26:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/ChangeLog,v 1.34 2012/08/06 00:11:45 ottxor Exp $
+
+*rfcutil-3.2.3-r2 (06 Aug 2012)
+
+ 06 Aug 2012; Christoph Junghans <ottxor@gentoo.org>
+ +files/rfc-3.2.3-paths.patch, +rfcutil-3.2.3-r2.ebuild:
+ add prefix changes
10 May 2012; Agostino Sarubbo <ago@gentoo.org> -rfcutil-3.2.3.ebuild:
Remove old
diff --git a/app-text/rfcutil/files/rfc-3.2.3-paths.patch b/app-text/rfcutil/files/rfc-3.2.3-paths.patch
new file mode 100644
index 000000000000..8d61bdbf3889
--- /dev/null
+++ b/app-text/rfcutil/files/rfc-3.2.3-paths.patch
@@ -0,0 +1,22 @@
+--- a/rfc-3.2.3/rfc-3.2.3
++++ b/rfc-3.2.3/rfc-3.2.3
+@@ -36,8 +36,8 @@
+
+ # These make it avail for all users if you can't
+ # run it as root. (full path, not ~/ )
+-$indexpath="/usr/local/etc/rfc-index";
+-$servpath="/usr/local/etc/nmap-services";
++$indexpath="@GENTOO_PORTAGE_EPREFIX@/var/cache/rfc/rfc-index";
++$servpath="@GENTOO_PORTAGE_EPREFIX@/etc/nmap-services";
+
+ ####################################
+ ## add as many urls as you please ##
+@@ -46,7 +46,7 @@
+ !http://www.faqs.org/rfcs/
+ http://www.isi.edu/in-notes/
+ http://www.cis.ohio-state.edu/htbin/rfc/
+- /local/path/to/rfcs/); #MAKE SURE you have the trailing slashes
++ @GENTOO_PORTAGE_EPREFIX@/var/cache/rfc/rfcs/); #MAKE SURE you have the trailing slashes
+ # URLs beginning with an ! are treated as HTML and not text
+
+ #######################
diff --git a/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild b/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
new file mode 100644
index 000000000000..d760cb36d18d
--- /dev/null
+++ b/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild,v 1.1 2012/08/06 00:11:45 ottxor Exp $
+
+EAPI=4
+
+inherit eutils prefix
+
+MY_PN="rfc"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="return all related RFCs based upon a number or a search string"
+HOMEPAGE="http://www.dewn.com/rfc/"
+SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ || ( www-client/lynx virtual/w3m )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${MY_P}-paths.patch \
+ "${FILESDIR}"/${MY_P}-index.patch
+ eprefixify ${MY_P}
+}
+
+src_install() {
+ newbin ${MY_P} ${MY_PN}
+ doman ${MY_PN}.1
+ dodoc CHANGELOG KNOWN_BUGS README
+ keepdir /var/cache/rfc
+}
+
+pkg_postinst() {
+ elog "Gaarde suggests you make a cron.monthly to run the following:"
+ elog " ${EPREFIX}/usr/bin/rfc -i"
+}
+
+pkg_prerm() {
+ rm -f "${EROOT}"/var/cache/rfc/*
+}