summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-05-18 12:37:19 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-05-18 12:37:19 +0000
commitb45e7a6199fa958051aad9c06ea216601dc2795b (patch)
tree10d84b04f38d249d196d462d6c392f5e60cf28ae /app-text
parentadded to ~mips for testing (diff)
downloadgentoo-2-b45e7a6199fa958051aad9c06ea216601dc2795b.tar.gz
gentoo-2-b45e7a6199fa958051aad9c06ea216601dc2795b.tar.bz2
gentoo-2-b45e7a6199fa958051aad9c06ea216601dc2795b.zip
Build library as .so rather than .a; resolves bugs #133583 and #126452; thanks to Hanno Meyer-Thurow and Flameeyes.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/hunspell/ChangeLog10
-rw-r--r--app-text/hunspell/files/digest-hunspell-1.1.4-r13
-rw-r--r--app-text/hunspell/files/hunspell-1.1.4-libtool.patch103
-rw-r--r--app-text/hunspell/files/hunspell-1.1.4-renameexes.patch114
-rw-r--r--app-text/hunspell/hunspell-1.1.4-r1.ebuild71
5 files changed, 300 insertions, 1 deletions
diff --git a/app-text/hunspell/ChangeLog b/app-text/hunspell/ChangeLog
index 0cb2b779c275..2e99ca10e40b 100644
--- a/app-text/hunspell/ChangeLog
+++ b/app-text/hunspell/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/hunspell
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.8 2006/05/18 00:35:46 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.9 2006/05/18 12:37:19 kevquinn Exp $
+
+*hunspell-1.1.4-r1 (18 May 2006)
+
+ 18 May 2006; Kevin F. Quinn <kevquinn@gentoo.org>
+ +files/hunspell-1.1.4-libtool.patch,
+ +files/hunspell-1.1.4-renameexes.patch, +hunspell-1.1.4-r1.ebuild:
+ Build library as .so rather than .a; resolves bugs #133583 and #126452.
+ Thanks to Hanno Meyer-Thurow and the ever-present Flameeyes.
18 May 2006; Gustavo Zacarias <gustavoz@gentoo.org> hunspell-1.1.4.ebuild:
Stable on sparc
diff --git a/app-text/hunspell/files/digest-hunspell-1.1.4-r1 b/app-text/hunspell/files/digest-hunspell-1.1.4-r1
new file mode 100644
index 000000000000..1bd701b1a28f
--- /dev/null
+++ b/app-text/hunspell/files/digest-hunspell-1.1.4-r1
@@ -0,0 +1,3 @@
+MD5 4cf2dfb89dd58392ad5a1183c69eb628 hunspell-1.1.4.tar.gz 438667
+RMD160 a90ded6b996d8b2d575268e8a4b025e92b85f378 hunspell-1.1.4.tar.gz 438667
+SHA256 8d39c03beb71ec1482d2fdbfc2d5b7690c8a70fb6da4885369752ee0d2e3a635 hunspell-1.1.4.tar.gz 438667
diff --git a/app-text/hunspell/files/hunspell-1.1.4-libtool.patch b/app-text/hunspell/files/hunspell-1.1.4-libtool.patch
new file mode 100644
index 000000000000..e7915e032b11
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.1.4-libtool.patch
@@ -0,0 +1,103 @@
+Index: hunspell-1.1.4/configure.ac
+===================================================================
+--- hunspell-1.1.4.orig/configure.ac
++++ hunspell-1.1.4/configure.ac
+@@ -23,7 +23,7 @@ AC_CONFIG_HEADER([config.h])
+ # Checks for programs.
+ AC_PROG_CXX
+ AC_PROG_CC
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ # Checks for libraries.
+
+Index: hunspell-1.1.4/src/hunspell/Makefile.am
+===================================================================
+--- hunspell-1.1.4.orig/src/hunspell/Makefile.am
++++ hunspell-1.1.4/src/hunspell/Makefile.am
+@@ -1,5 +1,5 @@
+-lib_LIBRARIES = libhunspell.a
+-libhunspell_a_SOURCES=affentry.cxx affixmgr.cxx csutil.cxx \
++lib_LTLIBRARIES = libhunspell.la
++libhunspell_la_SOURCES=affentry.cxx affixmgr.cxx csutil.cxx \
+ dictmgr.cxx hashmgr.cxx hunspell.cxx \
+ suggestmgr.cxx utf_info.cxx license.myspell license.hunspell
+
+Index: hunspell-1.1.4/src/hunspell/utf_info.cxx
+===================================================================
+--- hunspell-1.1.4.orig/src/hunspell/utf_info.cxx
++++ hunspell-1.1.4/src/hunspell/utf_info.cxx
+@@ -1,6 +1,6 @@
+ #include "csutil.hxx"
+ /* fields: Unicode letter, toupper, tolower */
+-struct unicode_info utf_lst[] = {
++static struct unicode_info utf_lst[] = {
+ { 0x0041, 0x0041, 0x0061 },
+ { 0x0042, 0x0042, 0x0062 },
+ { 0x0043, 0x0043, 0x0063 },
+Index: hunspell-1.1.4/src/parsers/Makefile.am
+===================================================================
+--- hunspell-1.1.4.orig/src/parsers/Makefile.am
++++ hunspell-1.1.4/src/parsers/Makefile.am
+@@ -1,7 +1,8 @@
+-lib_LIBRARIES=libparsers.a
+-libparsers_a_SOURCES=firstparser.cxx htmlparser.cxx \
++lib_LTLIBRARIES=libparsers.la
++libparsers_la_SOURCES=firstparser.cxx htmlparser.cxx \
+ latexparser.cxx manparser.cxx \
+ textparser.cxx
++libparsers_la_LIBADD = ../hunspell/libhunspell.la
+
+ #include_hunspelldir
+ include_HEADERS = firstparser.hxx \
+@@ -11,7 +12,6 @@ include_HEADERS = firstparser.hxx \
+ textparser.hxx
+
+ noinst_PROGRAMS=testparser
+-testparser_SOURCES=firstparser.cxx firstparser.hxx htmlparser.cxx htmlparser.hxx latexparser.cxx latexparser.hxx manparser.cxx manparser.hxx testparser.cxx textparser.cxx textparser.hxx
++testparser_SOURCES=testparser.cxx
++testparser_LDADD = libparsers.la
+
+-# need mystrdup()
+-LDADD = ../hunspell/libhunspell.a
+Index: hunspell-1.1.4/src/tools/Makefile.am
+===================================================================
+--- hunspell-1.1.4.orig/src/tools/Makefile.am
++++ hunspell-1.1.4/src/tools/Makefile.am
+@@ -7,18 +7,18 @@ unmunch_SOURCES=unmunch.c
+ include_HEADERS=munch.h unmunch.h
+
+ example_SOURCES=example.cxx
+-example_LDADD = ../hunspell/libhunspell.a
++example_LDADD = ../hunspell/libhunspell.la
+
+ hunspell_SOURCES=hunspell.cxx
+-hunspell_LDADD = @LIBINTL@ ../hunspell/libhunspell.a \
+- ../parsers/libparsers.a @CURSESLIB@ @READLINELIB@
++hunspell_LDADD = @LIBINTL@ ../hunspell/libhunspell.la \
++ ../parsers/libparsers.la @CURSESLIB@ @READLINELIB@
+
+ hunmorph_SOURCES=hunmorph.cxx
+-hunmorph_LDADD = ../hunspell/libhunspell.a
++hunmorph_LDADD = ../hunspell/libhunspell.la
+ #hunmorph_INCLUDES=-I${top_srcdir}/src/hunspell
+
+ hunstem_SOURCES=hunstem.cxx
+-hunstem_LDADD = ../hunspell/libhunspell.a
++hunstem_LDADD = ../hunspell/libhunspell.la
+ #hunstem_INCLUDES=-I${top_srcdir}/src/hunspell
+
+ EXTRA_DIST=makealias
+Index: hunspell-1.1.4/po/Makefile.in.in
+===================================================================
+--- hunspell-1.1.4.orig/po/Makefile.in.in
++++ hunspell-1.1.4/po/Makefile.in.in
+@@ -27,7 +27,7 @@ gettextsrcdir = $(datadir)/gettext/po
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = @MKINSTALLDIRS@
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
diff --git a/app-text/hunspell/files/hunspell-1.1.4-renameexes.patch b/app-text/hunspell/files/hunspell-1.1.4-renameexes.patch
new file mode 100644
index 000000000000..2e5c45cd7d46
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.1.4-renameexes.patch
@@ -0,0 +1,114 @@
+diff -u -ur hunspell-1.1.3.orig/src/tools/Makefile.am hunspell-1.1.3/src/tools/Makefile.am
+--- hunspell-1.1.3.orig/src/tools/Makefile.am 2006-01-27 19:32:19.000000000 +0100
++++ hunspell-1.1.3/src/tools/Makefile.am 2006-01-27 19:33:05.000000000 +0100
+@@ -1,13 +1,13 @@
+-bin_PROGRAMS=munch unmunch example hunspell hunmorph hunstem
++bin_PROGRAMS=hunspell-munch hunspell-unmunch hunspell-example hunspell hunmorph hunstem
+
+ INCLUDES=-I${top_srcdir}/src/hunspell -I${top_srcdir}/src/parsers
+
+-munch_SOURCES=munch.c
+-unmunch_SOURCES=unmunch.c
++hunspell_munch_SOURCES=munch.c
++hunspell_unmunch_SOURCES=unmunch.c
+ include_HEADERS=munch.h unmunch.h
+
+-example_SOURCES=example.cxx
+-example_LDADD = ../hunspell/libhunspell.la
++hunspell_example_SOURCES=example.cxx
++hunspell_example_LDADD = ../hunspell/libhunspell.la
+
+ hunspell_SOURCES=hunspell.cxx
+ hunspell_LDADD = @LIBINTL@ ../hunspell/libhunspell.la \
+diff -u -ur hunspell-1.1.3.orig/src/tools/example.cxx hunspell-1.1.3/src/tools/example.cxx
+--- hunspell-1.1.3.orig/src/tools/example.cxx 2006-01-27 19:32:19.000000000 +0100
++++ hunspell-1.1.3/src/tools/example.cxx 2006-01-27 19:33:31.000000000 +0100
+@@ -24,21 +24,21 @@
+ af = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"example affix_file dictionary_file file_of_words_to_check\n");
++ fprintf(stderr,"hunspell-example affix_file dictionary_file file_of_words_to_check\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ df = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"example affix_file dictionary_file file_of_words_to_check\n");
++ fprintf(stderr,"hunspell-example affix_file dictionary_file file_of_words_to_check\n");
+ exit(1);
+ }
+ if (argv[3]) {
+ wtc = mystrdup(argv[3]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"example affix_file dictionary_file file_of_words_to_check\n");
++ fprintf(stderr,"hunspell-example affix_file dictionary_file file_of_words_to_check\n");
+ exit(1);
+ }
+
+diff -u -ur hunspell-1.1.3.orig/src/tools/hunmorph.cxx hunspell-1.1.3/src/tools/hunmorph.cxx
+--- hunspell-1.1.3.orig/src/tools/hunmorph.cxx 2006-01-27 19:32:19.000000000 +0100
++++ hunspell-1.1.3/src/tools/hunmorph.cxx 2006-01-27 19:35:18.000000000 +0100
+@@ -26,7 +26,7 @@
+
+ for (i = 1; i < 3; i++)
+ if (!argv[i]) {
+- fprintf(stderr, "correct syntax is:\nexample affix_file");
++ fprintf(stderr, "correct syntax is:\nhunmorph affix_file");
+ fprintf(stderr, " dictionary_file file_of_words_to_check\n");
+ exit(1);
+ }
+diff -u -ur hunspell-1.1.3.orig/src/tools/hunstem.cxx hunspell-1.1.3/src/tools/hunstem.cxx
+--- hunspell-1.1.3.orig/src/tools/hunstem.cxx 2006-01-27 19:32:19.000000000 +0100
++++ hunspell-1.1.3/src/tools/hunstem.cxx 2006-01-27 19:35:28.000000000 +0100
+@@ -25,7 +25,7 @@
+
+ for (i = 1; i < 3; i++)
+ if (!argv[i]) {
+- fprintf(stderr, "correct syntax is:\nexample affix_file");
++ fprintf(stderr, "correct syntax is:\nhunstem affix_file");
+ fprintf(stderr, " dictionary_file file_of_words_to_check\n");
+ exit(1);
+ }
+diff -u -ur hunspell-1.1.3.orig/src/tools/munch.c hunspell-1.1.3/src/tools/munch.c
+--- hunspell-1.1.3.orig/src/tools/munch.c 2006-01-27 19:32:19.000000000 +0100
++++ hunspell-1.1.3/src/tools/munch.c 2006-01-27 19:33:56.000000000 +0100
+@@ -42,14 +42,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+
+diff -u -ur hunspell-1.1.3.orig/src/tools/unmunch.c hunspell-1.1.3/src/tools/unmunch.c
+--- hunspell-1.1.3.orig/src/tools/unmunch.c 2006-01-27 19:32:19.000000000 +0100
++++ hunspell-1.1.3/src/tools/unmunch.c 2006-01-27 19:34:10.000000000 +0100
+@@ -39,14 +39,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+
diff --git a/app-text/hunspell/hunspell-1.1.4-r1.ebuild b/app-text/hunspell/hunspell-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..644f3a84d42b
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.1.4-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/hunspell-1.1.4-r1.ebuild,v 1.1 2006/05/18 12:37:19 kevquinn Exp $
+
+inherit eutils multilib autotools libtool
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses readline"
+KEYWORDS="~ppc ~sparc ~x86"
+
+DEPEND="readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:tail +:tail -n +:' ${S}/tests/test.sh ||\
+ die "Failed to fix-up tail for POSIX compliance"
+ # Rework to use libtool, so as to get shared libraries
+ # where appropriate, instead of the archive-only approach
+ # taken upstream.
+ epatch "${FILESDIR}/${P}-libtool.patch"
+ # Upstream package creates executables 'example', 'munch'
+ # and 'unmunch' which are too generic to be placed in
+ # /usr/bin - this patch prefixes them with 'hunspell-'.
+ # Also includes a small change for libtool.
+ epatch "${FILESDIR}/${P}-renameexes.patch"
+
+ # Makefile.am modified, libtool added, hence autoreconfi
+ # and elibtoolize.
+ WANT_AUTOMAKE="1.9" eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ # I wanted to put the include files in /usr/include/hunspell
+ # but this means the openoffice build won't find them.
+ econf \
+ --includedir=/usr/include/hunspell \
+ $(use_with readline readline) \
+ $(use_with ncurses ui) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_test() {
+ # One of the tests doesn't like LC_ALL being set to encodings
+ # capable of expressing beta-S, so we simply clear it.
+ # bug #125375
+ LC_ALL="C" make check
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ # hunspell is derived from myspell
+ dodoc AUTHORS.myspell README.myspell license.myspell
+}
+
+pkg_postinst() {
+ einfo "To use this package you will also need a dictionary."
+ einfo "Hunspell uses myspell format dictionaries; find them"
+ einfo "in the app-dicts category as myspell-<LANG>."
+}