summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-29 07:17:22 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-29 07:17:22 +0000
commit97f81864a17230a89acb6242e4685a6b753a1acc (patch)
tree970c2d2ec939b4b4f074186f2661fcccc237fbba /app-vim/gnupg
parentRemove old versions. (diff)
downloadgentoo-2-97f81864a17230a89acb6242e4685a6b753a1acc.tar.gz
gentoo-2-97f81864a17230a89acb6242e4685a6b753a1acc.tar.bz2
gentoo-2-97f81864a17230a89acb6242e4685a6b753a1acc.zip
Version bump.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/gnupg')
-rw-r--r--app-vim/gnupg/ChangeLog7
-rw-r--r--app-vim/gnupg/gnupg-2.3.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-vim/gnupg/ChangeLog b/app-vim/gnupg/ChangeLog
index 24ffb4c36738..3f934f58ef9c 100644
--- a/app-vim/gnupg/ChangeLog
+++ b/app-vim/gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/gnupg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gnupg/ChangeLog,v 1.2 2011/08/17 03:42:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gnupg/ChangeLog,v 1.3 2011/11/29 07:17:22 radhermit Exp $
+
+*gnupg-2.3 (29 Nov 2011)
+
+ 29 Nov 2011; Tim Harder <radhermit@gentoo.org> +gnupg-2.3.ebuild:
+ Version bump.
*gnupg-2.2 (17 Aug 2011)
diff --git a/app-vim/gnupg/gnupg-2.3.ebuild b/app-vim/gnupg/gnupg-2.3.ebuild
new file mode 100644
index 000000000000..76b1a40490c5
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gnupg/gnupg-2.3.ebuild,v 1.1 2011/11/29 07:17:22 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: transparent editing of gpg encrypted files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3645"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-crypt/gnupg"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt
+}