summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-04 11:38:08 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-04 11:38:08 +0000
commit5267292e5b8ccad737933ab9a5bafa827bf5ac22 (patch)
tree3f2f2a3bf6e040ad405f09b929c19b39a303860a /app-vim
parentRevision bump and remove old. Remove .DS_Store files that should not be insta... (diff)
downloadgentoo-2-5267292e5b8ccad737933ab9a5bafa827bf5ac22.tar.gz
gentoo-2-5267292e5b8ccad737933ab9a5bafa827bf5ac22.tar.bz2
gentoo-2-5267292e5b8ccad737933ab9a5bafa827bf5ac22.zip
Initial import.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimcalc/ChangeLog10
-rw-r--r--app-vim/vimcalc/metadata.xml5
-rw-r--r--app-vim/vimcalc/vimcalc-1.3.ebuild27
3 files changed, 42 insertions, 0 deletions
diff --git a/app-vim/vimcalc/ChangeLog b/app-vim/vimcalc/ChangeLog
new file mode 100644
index 000000000000..744e99b927e8
--- /dev/null
+++ b/app-vim/vimcalc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/vimcalc
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcalc/ChangeLog,v 1.1 2011/05/04 11:38:08 radhermit Exp $
+
+*vimcalc-1.3 (04 May 2011)
+
+ 04 May 2011; Tim Harder <radhermit@gentoo.org> +vimcalc-1.3.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/vimcalc/metadata.xml b/app-vim/vimcalc/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/vimcalc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/vimcalc/vimcalc-1.3.ebuild b/app-vim/vimcalc/vimcalc-1.3.ebuild
new file mode 100644
index 000000000000..682db4f65c31
--- /dev/null
+++ b/app-vim/vimcalc/vimcalc-1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcalc/vimcalc-1.3.ebuild,v 1.1 2011/05/04 11:38:08 radhermit Exp $
+
+EAPI="4"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: provides an interactive calculator inside vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3329"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=15317 -> ${P}.zip"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimcalc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ dev-lang/python"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ # Remove .DS_Store files that should not be installed
+ find -type f -name '.*' -exec rm -f {} + || die
+}