summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-25 00:34:15 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-25 00:34:15 +0000
commit7d386b1d8f47f2d25935bdb7cdb5babda6ea914d (patch)
tree606a285572ebce7548d9c7d62622f383133b8e89 /app-vim
parentVersion bump (diff)
downloadgentoo-2-7d386b1d8f47f2d25935bdb7cdb5babda6ea914d.tar.gz
gentoo-2-7d386b1d8f47f2d25935bdb7cdb5babda6ea914d.tar.bz2
gentoo-2-7d386b1d8f47f2d25935bdb7cdb5babda6ea914d.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/fugitive/ChangeLog8
-rw-r--r--app-vim/fugitive/fugitive-2.1.ebuild23
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild14
3 files changed, 40 insertions, 5 deletions
diff --git a/app-vim/fugitive/ChangeLog b/app-vim/fugitive/ChangeLog
index e91a263149fb..c04a1015272b 100644
--- a/app-vim/fugitive/ChangeLog
+++ b/app-vim/fugitive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/fugitive
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/ChangeLog,v 1.7 2014/06/19 05:32:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/ChangeLog,v 1.8 2014/06/25 00:34:15 radhermit Exp $
+
+*fugitive-2.1 (25 Jun 2014)
+
+ 25 Jun 2014; Tim Harder <radhermit@gentoo.org> +fugitive-2.1.ebuild,
+ fugitive-9999.ebuild:
+ Version bump.
*fugitive-9999 (19 Jun 2014)
*fugitive-2.0_beta (19 Jun 2014)
diff --git a/app-vim/fugitive/fugitive-2.1.ebuild b/app-vim/fugitive/fugitive-2.1.ebuild
new file mode 100644
index 000000000000..3ffc20f787e7
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/fugitive-2.1.ebuild,v 1.1 2014/06/25 00:34:15 radhermit Exp $
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index d340b2fdca0e..3c0afc429f32 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,12 +1,18 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/fugitive-9999.ebuild,v 1.1 2014/06/19 05:32:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/fugitive-9999.ebuild,v 1.2 2014/06/25 00:34:15 radhermit Exp $
EAPI=5
+inherit vim-plugin
-inherit vim-plugin git-r3
-
-EGIT_REPO_URI="git://github.com/tpope/vim-fugitive.git"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+fi
DESCRIPTION="vim plugin: a git wrapper for vim"
HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"