summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-02 22:48:26 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-02 22:48:26 +0000
commitd08c9eafa2f1465bd7b90f525547f53da84a8e88 (patch)
tree5370bbda1061613331c24d3009a8c8fc48314b7a /berlin-base
parent*** empty log message *** (diff)
downloadgentoo-2-d08c9eafa2f1465bd7b90f525547f53da84a8e88.tar.gz
gentoo-2-d08c9eafa2f1465bd7b90f525547f53da84a8e88.tar.bz2
gentoo-2-d08c9eafa2f1465bd7b90f525547f53da84a8e88.zip
*** empty log message ***
Diffstat (limited to 'berlin-base')
-rw-r--r--berlin-base/berlin/berlin-0.2.2.ebuild40
-rw-r--r--berlin-base/berlin/files/digest-berlin-0.2.27
-rw-r--r--berlin-base/omniORB/files/digest-omniORB-3031
-rw-r--r--berlin-base/omniORB/omniORB-303.ebuild20
4 files changed, 60 insertions, 8 deletions
diff --git a/berlin-base/berlin/berlin-0.2.2.ebuild b/berlin-base/berlin/berlin-0.2.2.ebuild
new file mode 100644
index 000000000000..2c5444e8d7d8
--- /dev/null
+++ b/berlin-base/berlin/berlin-0.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/berlin-base/berlin/berlin-0.2.2.ebuild,v 1.1 2001/05/02 22:48:26 achim Exp $
+
+A0=Berlin-${PV}.tar.bz2
+A1=Prague-${PV}.tar.bz2
+A2=Warsaw-${PV}.tar.bz2
+A3=Babylon-${PV}.tar.bz2
+A4=Berlin-Server-${PV}.tar.bz2
+A5=Berlin-Clients-Perl-${PV}.tar.bz2
+A6=Berlin-Clients-Python-${PV}.tar.bz2
+A="$A0 $A1 $A2 $A3 $A4 $A5 $A6"
+S=${WORKDIR}/Berlin-${PV}
+DESCRIPTION="A new alternative to X"
+SRC_URI="http://prdownloads.sourceforge.net/berlin/${A0}
+ http://prdownloads.sourceforge.net/berlin/${A1}
+ http://prdownloads.sourceforge.net/berlin/${A2}
+ http://prdownloads.sourceforge.net/berlin/${A3}
+ http://prdownloads.sourceforge.net/berlin/${A4}
+ http://prdownloads.sourceforge.net/berlin/${A5}
+ http://prdownloads.sourceforge.net/berlin/${A6}"
+
+HOMEPAGE="http://www.berlin-consortium.org"
+
+DEPEND=""
+
+src_compile() {
+
+ try ./configure --prefix=/opt/berlin --host=${CHOST} \
+ --with-directfb-prefix=/usr --with-omniorb-prefix=/opt/berlin
+ try make
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+}
+
diff --git a/berlin-base/berlin/files/digest-berlin-0.2.2 b/berlin-base/berlin/files/digest-berlin-0.2.2
new file mode 100644
index 000000000000..44e6c185d7c8
--- /dev/null
+++ b/berlin-base/berlin/files/digest-berlin-0.2.2
@@ -0,0 +1,7 @@
+MD5 e283c2f30732081621f75f5a4e87c595 Berlin-0.2.2.tar.bz2
+MD5 4dfafc6163132c99fdd3ecbb008d6b2d Prague-0.2.2.tar.bz2
+MD5 04649c9fc055869968a8fecd0634ae4b Warsaw-0.2.2.tar.bz2
+MD5 8bc482ea367c8a29cac2564859ad17d9 Babylon-0.2.2.tar.bz2
+MD5 e3770919075f1e9186acc9e2fdb6cf83 Berlin-Server-0.2.2.tar.bz2
+MD5 97db2cad0a8cf718b040422a0c4278b5 Berlin-Clients-Perl-0.2.2.tar.bz2
+MD5 51da0289b7a2698f228036b608511cb4 Berlin-Clients-Python-0.2.2.tar.bz2
diff --git a/berlin-base/omniORB/files/digest-omniORB-303 b/berlin-base/omniORB/files/digest-omniORB-303
index 6162c1bb669d..5c9a1660fdab 100644
--- a/berlin-base/omniORB/files/digest-omniORB-303
+++ b/berlin-base/omniORB/files/digest-omniORB-303
@@ -1 +1,2 @@
MD5 221e68ca295c9bbcf2e23491a0d0dc2c omniORB_303.tar.gz
+MD5 d2926e018d572d338716eeb53497d95b omniORBpy_1_3.tar.gz
diff --git a/berlin-base/omniORB/omniORB-303.ebuild b/berlin-base/omniORB/omniORB-303.ebuild
index d42a820587be..2df05f70527b 100644
--- a/berlin-base/omniORB/omniORB-303.ebuild
+++ b/berlin-base/omniORB/omniORB-303.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/berlin-base/omniORB/omniORB-303.ebuild,v 1.3 2001/05/02 18:59:33 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/berlin-base/omniORB/omniORB-303.ebuild,v 1.4 2001/05/02 22:48:26 achim Exp $
-A=${PN}_${PV}.tar.gz
+A="${PN}_${PV}.tar.gz omniORBpy_1_3.tar.gz"
S=${WORKDIR}/omni
DESCRIPTION="a robust, high-performance CORBA 2 ORB"
-SRC_URI="ftp://ftp.uk.research.att.com/pub/omniORB/omniORB3/${A}"
+SRC_URI="ftp://ftp.uk.research.att.com/pub/omniORB/omniORB3/${PN}_${PV}.tar.gz
+ ftp://ftp.uk.research.att.com/pub/omniORB/omniORBpy/${PN}py_1_3.tar.gz"
HOMEPAGE="http://www.uk.research.att.com/omniORB/"
DEPEND=""
@@ -15,7 +16,9 @@ PLT="i586_linux_2.0_glibc2.1"
src_unpack() {
- unpack ${A}
+ unpack ${PN}_${PV}.tar.gz
+ cd ${S}/src/lib
+ unpack ${PN}py_1_3.tar.gz
cd ${S}/config
cp config.mk config.mk.orig
@@ -38,7 +41,8 @@ src_compile() {
cd src
try make export
-
+ cd src/lib/omniORBpy
+ try make export
}
src_install () {
@@ -46,7 +50,7 @@ src_install () {
T=/opt/berlin
into ${T}
cd ${S}
- dobin bin/${PLT}/*
+ dobin bin/${PLT}/* bin/scripts/*
insinto ${T}/lib/idl
doins idl/*.idl
insinto ${T}/lib/idl/COS
@@ -55,8 +59,8 @@ src_install () {
dolib lib/${PLT}/*.{a,so*}
exeinto ${T}/lib
doexe lib/${PLT}/omnicpp
- dodir /usr/lib/python2.0
- cp -af lib/python/* ${D}/usr/lib/python2.0/
+ dodir ${T}/lib/python
+ cp -af lib/python/* ${D}/${T}/lib/python/
doman man/man[15]/*.[15]
dodoc CHANGES* COPYING* CREDITS PORTING README* ReleaseNote_omniORB_303 THIS_IS_omniORB_3_0_3