summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-02-23 09:44:49 +0000
committerDavid Holm <dholm@gentoo.org>2005-02-23 09:44:49 +0000
commit2c2000087270ae53ee5c3430930d49580feccd7b (patch)
treebca62e2a58927d9158c8ffe91d292495ee618d89 /dev-ada
parentMarked 208 as stable, fixes #81633. (diff)
downloadgentoo-2-2c2000087270ae53ee5c3430930d49580feccd7b.tar.gz
gentoo-2-2c2000087270ae53ee5c3430930d49580feccd7b.tar.bz2
gentoo-2-2c2000087270ae53ee5c3430930d49580feccd7b.zip
Closed bug #72383
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/florist/ChangeLog8
-rw-r--r--dev-ada/florist/files/florist-3.15p-fix.patch13
-rw-r--r--dev-ada/florist/florist-3.15p.ebuild12
3 files changed, 29 insertions, 4 deletions
diff --git a/dev-ada/florist/ChangeLog b/dev-ada/florist/ChangeLog
index 1f9f548b072b..d1aff1f658fd 100644
--- a/dev-ada/florist/ChangeLog
+++ b/dev-ada/florist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ada/florist
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/florist/ChangeLog,v 1.9 2005/01/01 17:24:25 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/florist/ChangeLog,v 1.10 2005/02/23 09:44:49 dholm Exp $
+
+ 23 Feb 2005; David Holm <dholm@gentoo.org> +files/florist-3.15p-fix.patch,
+ florist-3.15p.ebuild:
+ Added compilation fix submitted by David Barbassat <david (dot) barbassat
+ (at) nerim (dot) net> (Bug #72383)
+ Stable on ppc
29 Jun 2004; Aron Griffis <agriffis@gentoo.org> florist-3.15p.ebuild:
add sed-4 dep
diff --git a/dev-ada/florist/files/florist-3.15p-fix.patch b/dev-ada/florist/files/florist-3.15p-fix.patch
new file mode 100644
index 000000000000..b03302cc5048
--- /dev/null
+++ b/dev-ada/florist/files/florist-3.15p-fix.patch
@@ -0,0 +1,13 @@
+--- c-posix.c.orig 2002-10-24 11:03:51.000000000 +0300
++++ c-posix.c 2005-01-12 20:19:24.000000000 +0200
+@@ -6344,8 +6344,8 @@
+ g_struct_msghdr();
+ gcmnt("local socket address");
+ { struct sockaddr_un DUMMY;
+- ifprintf(fp," subtype sun_path_string is
+- POSIX_String (1 .. %d);\n", sizeof (DUMMY.sun_path));
++ ifprintf(fp," subtype sun_path_string is\n"
++ " POSIX_String (1 .. %d);\n", sizeof (DUMMY.sun_path));
+ }
+ g_struct_sockaddr_un();
+ gcmnt("internet socket address");
diff --git a/dev-ada/florist/florist-3.15p.ebuild b/dev-ada/florist/florist-3.15p.ebuild
index 0133a18bd072..3d6c372c50de 100644
--- a/dev-ada/florist/florist-3.15p.ebuild
+++ b/dev-ada/florist/florist-3.15p.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/florist/florist-3.15p.ebuild,v 1.8 2005/01/01 17:24:25 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/florist/florist-3.15p.ebuild,v 1.9 2005/02/23 09:44:49 dholm Exp $
inherit gnat
@@ -8,16 +8,22 @@ DESCRIPTION="POSIX Ada Bindings"
HOMEPAGE="http://www.cs.fsu.edu/~baker/florist.html"
SRC_URI="ftp://cs.nyu.edu/pub/gnat/3.15p/florist-3.15p-src.tgz"
-DEPEND="<dev-lang/gnat-5.0
+DEPEND="<dev-lang/gnat-3.41
>=sys-apps/sed-4"
RDEPEND=""
LICENSE="GMGPL"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="x86 ppc"
IUSE=""
S="${WORKDIR}/${P}-src"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix.patch
+}
+
src_compile() {
sed -i -e "s:GCST(\"SIGRTMAX\", SIGRTMAX:GCST(\"SIGRTMAX\", (NSIG - 1):" c-posix.c
econf || die "./configure failed"