summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-25 19:05:23 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-25 19:05:23 +0000
commit2d6f8f504a9d66f5ea7dd37599b31cccaccc6010 (patch)
tree6889a830006dec4c936d6fbd8d709d00a83d172e /dev-ada
parentDrop old ebuilds. Fix Qt4 deps (including bugs 245123 and 269337). (diff)
downloadgentoo-2-2d6f8f504a9d66f5ea7dd37599b31cccaccc6010.tar.gz
gentoo-2-2d6f8f504a9d66f5ea7dd37599b31cccaccc6010.tar.bz2
gentoo-2-2d6f8f504a9d66f5ea7dd37599b31cccaccc6010.zip
Drop old ebuild with illegal qt4 dep
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/qtada/ChangeLog7
-rw-r--r--dev-ada/qtada/qtada-1.0.3.ebuild84
2 files changed, 5 insertions, 86 deletions
diff --git a/dev-ada/qtada/ChangeLog b/dev-ada/qtada/ChangeLog
index 48f3352cd283..ac00ab2a3505 100644
--- a/dev-ada/qtada/ChangeLog
+++ b/dev-ada/qtada/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ada/qtada
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/qtada/ChangeLog,v 1.3 2008/10/23 14:17:58 george Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/qtada/ChangeLog,v 1.4 2009/06/25 19:05:23 yngwin Exp $
+
+ 25 Jun 2009; Ben de Groot <yngwin@gentoo.org> -qtada-1.0.3.ebuild:
+ Drop old ebuild with illegal qt4 dep
23 Oct 2008; George Shapovalov <george@gentoo.org> qtada-1.0.4.ebuild:
fixed missing deps and USE (#241760), thanks to Philipp Riegger for report
diff --git a/dev-ada/qtada/qtada-1.0.3.ebuild b/dev-ada/qtada/qtada-1.0.3.ebuild
deleted file mode 100644
index 61dffa25891e..000000000000
--- a/dev-ada/qtada/qtada-1.0.3.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/qtada/qtada-1.0.3.ebuild,v 1.2 2008/05/21 16:42:20 mr_bones_ Exp $
-
-# We only need gnat.eclass for a few vars and helper functions.
-# We will not use src_* functions though.
-inherit eutils multilib gnat
-
-IUSE=""
-
-DESCRIPTION="Ada bindings for Qt library"
-HOMEPAGE="http://www.qtada.com/"
-SRC_URI="mirror://sourceforge/qtada/${PN}-gpl-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-
-# qtada is quite picky atm. For example this version will only compile with
-# the specified gnat, not even gnat-gcc-4.3.0 for example.
-RDEPEND="=dev-lang/gnat-gpl-4.1*
- dev-ada/asis-gpl
- >=x11-libs/qt-4.2.0"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PN}-gpl-${PV}"
-
-#LIBDIR=/usr/lib/ada/i686-pc-linux-gnu-gnat-gpl-4.1/qtada
-
-pkg_setup() {
- local ActiveGnat=$(get_active_profile)
- if [[ ! ${ActiveGnat} =~ "gnat-gpl-4.1" ]]; then
- ewarn "This version of qtada can only be compiled with gnat-gpl-4.1"
- die "Please switch to gnat-gpl-4.1 and try again"
- fi
- if ! built_with_use ">=x11-libs/qt-4.0" accessibility ; then
- die "Rebuild qt-4 with USE=accessibility"
- fi
-}
-
-# As this version of qtada only compiles with gnat-gpl-4.1 and we already
-# verified that it is active, we do not switch profiles or do any majic here.
-# We simplt run build once, just need to set some path appropriately.
-src_compile() {
- econf --datadir=${AdalibDataDir}/${PN} \
- --includedir=${AdalibSpecsDir}/${PN} \
- --libdir=${AdalibLibTop}/$(get_active_profile)/${PN} || die "econf failed"
- emake || die "make failed"
-}
-
-src_install() {
- # set common part of the path
- local InstTop=${AdalibLibTop}/$(get_active_profile)
-
- # run upstream setup
- einstall \
- libdir=${D}/${InstTop}/${PN} \
- bindir=${D}/${InstTop}/bin \
- includedir=${D}/${AdalibSpecsDir} || die "install failed"
-
- # move .ali file together with .so's
- mv "${D}"/${InstTop}/${PN}/${PN}/*.ali "${D}"/${InstTop}/${PN}/
- rmdir "${D}"/${InstTop}/${PN}/${PN}/
-
- # arrange and fix gpr files
- mv "${D}"/${InstTop}/${PN}/gnat "${D}"/${InstTop}/gpr
- sed -i -e "s:/usr/include:${AdalibSpecsDir}:" \
- -e "s:/usr/lib:${InstTop}/${PN}:" \
- -e "s:${PN}/${PN}:${PN}" "${D}"/${InstTop}/gpr/*.gpr
-
- # Create an environment file
- local SpecFile="${D}/usr/share/gnat/eselect/${PN}/$(get_active_profile)"
- dodir /usr/share/gnat/eselect/${PN}/
- echo "PATH=${InstTop}/bin" > "${SpecFile}"
- echo "ADA_INCLUDE_PATH=${AdalibSpecsDir}/${PN}/core" >> "${SpecFile}"
- echo "ADA_OBJECTS_PATH=${InstTop}/${PN}" >> "${SpecFile}"
- echo "ADA_PROJECT_PATH=${InstTop}/gpr" >> "${SpecFile}"
-
- # install docs
- dodoc AUTHORS NEWS README
- mv "${D}"/usr/examples/${PN} "${D}"/usr/share/doc/${PF}/examples
- rmdir "${D}"/usr/examples/
-}