summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-09 22:05:30 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-09 22:05:30 +0000
commit658a46e7095065b00b381d2e9627acf36a2f9d67 (patch)
tree689841740b81fc86b538aae3d1c72d7b39b30e28 /dev-cpp/glibmm/glibmm-2.34.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-658a46e7095065b00b381d2e9627acf36a2f9d67.tar.gz
gentoo-2-658a46e7095065b00b381d2e9627acf36a2f9d67.tar.bz2
gentoo-2-658a46e7095065b00b381d2e9627acf36a2f9d67.zip
Bump for glib-2.34 support. Update license. Drop old.
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-cpp/glibmm/glibmm-2.34.1.ebuild')
-rw-r--r--dev-cpp/glibmm/glibmm-2.34.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.34.1.ebuild b/dev-cpp/glibmm/glibmm-2.34.1.ebuild
new file mode 100644
index 000000000000..4a1746d51c90
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.34.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.34.1.ebuild,v 1.1 2012/12/09 22:05:30 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2/1" # subslot is libglibmm-2.4 soname suffix
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug examples test"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.10:2
+ >=dev-libs/glib-2.34:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="${G2CONF}
+ $(use_enable debug debug-refcounting)
+ $(use_enable doc documentation)
+ --enable-deprecated-api"
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ cd "${S}/tests/"
+ emake check
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+src_install() {
+ gnome2_src_install
+
+ if ! use doc && ! use examples; then
+ rm -fr "${ED}usr/share/doc/glibmm*"
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ dodoc -r examples
+ fi
+}