summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-08-09 08:51:25 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-08-09 08:51:25 +0000
commit13e2d9d6bdc13d7a8fcf68aba4553309b4aa86ae (patch)
tree4a2187702305f265870a7d2e7c4e8997a2ac7f53 /dev-cpp/libcmis
parentFix vala/zeitgeist compilation problems (#471368 by Peter Alfredsen, #479600 ... (diff)
downloadgentoo-2-13e2d9d6bdc13d7a8fcf68aba4553309b4aa86ae.tar.gz
gentoo-2-13e2d9d6bdc13d7a8fcf68aba4553309b4aa86ae.tar.bz2
gentoo-2-13e2d9d6bdc13d7a8fcf68aba4553309b4aa86ae.zip
Version bump to another branch of libcmis (to be used in libo4.2).
(Portage version: 2.2.0_alpha194/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-cpp/libcmis')
-rw-r--r--dev-cpp/libcmis/ChangeLog8
-rw-r--r--dev-cpp/libcmis/libcmis-0.4.1.ebuild67
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild4
3 files changed, 76 insertions, 3 deletions
diff --git a/dev-cpp/libcmis/ChangeLog b/dev-cpp/libcmis/ChangeLog
index d6ee8ac644c3..c48a7e53b11d 100644
--- a/dev-cpp/libcmis/ChangeLog
+++ b/dev-cpp/libcmis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libcmis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.26 2013/07/10 07:53:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.27 2013/08/09 08:51:25 scarabeus Exp $
+
+*libcmis-0.4.1 (09 Aug 2013)
+
+ 09 Aug 2013; Tomáš Chvátal <scarabeus@gentoo.org> +libcmis-0.4.1.ebuild,
+ libcmis-9999.ebuild:
+ Version bump to another branch of libcmis (to be used in libo4.2).
10 Jul 2013; Tomáš Chvátal <scarabeus@gentoo.org> libcmis-0.2.3-r1.ebuild,
libcmis-0.3.1.ebuild, libcmis-9999.ebuild:
diff --git a/dev-cpp/libcmis/libcmis-0.4.1.ebuild b/dev-cpp/libcmis/libcmis-0.4.1.ebuild
new file mode 100644
index 000000000000..9ef3405336f6
--- /dev/null
+++ b/dev-cpp/libcmis/libcmis-0.4.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.4.1.ebuild,v 1.1 2013/08/09 08:51:25 scarabeus Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://gitorious.org/libcmis/libcmis.git"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="git-2"
+inherit eutils alternatives autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="C++ client library for the CMIS interface"
+HOMEPAGE="https://sourceforge.net/projects/libcmis/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
+SLOT="0.4"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs man test"
+
+RDEPEND="
+ !dev-cpp/libcmis:0
+ dev-libs/boost:=
+ dev-libs/libxml2
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ man? (
+ app-text/docbook2X
+ dev-libs/libxslt
+ )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT} \
+ --disable-werror \
+ $(use_with man) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ --disable-long-tests \
+ --enable-client
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index b28b0e60aad6..871840d15668 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.11 2013/07/10 07:53:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.12 2013/08/09 08:51:25 scarabeus Exp $
EAPI=5
@@ -14,7 +14,7 @@ HOMEPAGE="https://sourceforge.net/projects/libcmis/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.3"
+SLOT="0.4"
# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} == 9999 ]] || \