summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-03 08:54:32 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-03 08:54:32 +0000
commit28f70b6fc46f8ad99059f1f0a86140ed56724e63 (patch)
tree3c1c19dc49b54231d67901dd82382bb1922ae323 /dev-cpp/libcmis
parentmake gdk-pixbuf-query-loaders more atomic, fix segfault due to __GL_NO_DSO_FI... (diff)
downloadgentoo-2-28f70b6fc46f8ad99059f1f0a86140ed56724e63.tar.gz
gentoo-2-28f70b6fc46f8ad99059f1f0a86140ed56724e63.tar.bz2
gentoo-2-28f70b6fc46f8ad99059f1f0a86140ed56724e63.zip
Initial commit, required for libreoffice.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/libcmis')
-rw-r--r--dev-cpp/libcmis/ChangeLog10
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild46
-rw-r--r--dev-cpp/libcmis/metadata.xml5
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-cpp/libcmis/ChangeLog b/dev-cpp/libcmis/ChangeLog
new file mode 100644
index 000000000000..bc56b35d064f
--- /dev/null
+++ b/dev-cpp/libcmis/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-cpp/libcmis
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.1 2011/10/03 08:54:32 scarabeus Exp $
+
+*libcmis-9999 (03 Oct 2011)
+
+ 03 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> +libcmis-9999.ebuild,
+ +metadata.xml:
+ Initial commit, required for libreoffice.
+
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
new file mode 100644
index 000000000000..1e6b74bbd7f4
--- /dev/null
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.1 2011/10/03 08:54:32 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://gitorious.org/libcmis/libcmis.git"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="git-2"
+inherit autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="C++ client library for the CMIS interface"
+HOMEPAGE="http://gitorious.org/libcmis"
+[[ ${PV} == 9999 ]] || SRC_URI=""
+
+LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/libxml2
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+"
+
+# It fetches the apache chemistry webapp and then try to run some magic on it
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-client
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-cpp/libcmis/metadata.xml b/dev-cpp/libcmis/metadata.xml
new file mode 100644
index 000000000000..fb56680f3630
--- /dev/null
+++ b/dev-cpp/libcmis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>openoffice</herd>
+</pkgmetadata>