summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-12-31 13:39:49 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-12-31 13:39:49 +0000
commitcc643a7df0757849c8500516fbe344fb32f380ba (patch)
treeaf3b2399a9ffee3d32c342080174372755e47f32 /dev-cpp/poslib
parentnew version (Manifest recommit) (diff)
downloadgentoo-2-cc643a7df0757849c8500516fbe344fb32f380ba.tar.gz
gentoo-2-cc643a7df0757849c8500516fbe344fb32f380ba.tar.bz2
gentoo-2-cc643a7df0757849c8500516fbe344fb32f380ba.zip
Version bumped. Removed old verison.
Diffstat (limited to 'dev-cpp/poslib')
-rw-r--r--dev-cpp/poslib/ChangeLog9
-rw-r--r--dev-cpp/poslib/Manifest2
-rw-r--r--dev-cpp/poslib/files/digest-poslib-1.0.21
-rw-r--r--dev-cpp/poslib/files/digest-poslib-1.0.61
-rw-r--r--dev-cpp/poslib/poslib-1.0.6.ebuild (renamed from dev-cpp/poslib/poslib-1.0.2.ebuild)10
5 files changed, 18 insertions, 5 deletions
diff --git a/dev-cpp/poslib/ChangeLog b/dev-cpp/poslib/ChangeLog
index c4d5ce5dfd3d..78764f9cd71c 100644
--- a/dev-cpp/poslib/ChangeLog
+++ b/dev-cpp/poslib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/poslib
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/ChangeLog,v 1.10 2004/12/14 09:32:26 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/ChangeLog,v 1.11 2004/12/31 13:39:49 matsuu Exp $
+
+*poslib-1.0.6 (31 Dec 2004)
+
+ 31 Dec 2004; MATSUU Takuto <matsuu@gentoo.org> -poslib-1.0.2.ebuild,
+ +poslib-1.0.6.ebuild:
+ Version bumped.
+ Removed old versions.
14 Dec 2004; MATSUU Takuto <matsuu@gentoo.org> poslib-1.0.4.ebuild:
Marked as stable.
diff --git a/dev-cpp/poslib/Manifest b/dev-cpp/poslib/Manifest
index 199ce9e7d914..5d1646f6a5d4 100644
--- a/dev-cpp/poslib/Manifest
+++ b/dev-cpp/poslib/Manifest
@@ -1,8 +1,10 @@
MD5 4164b852526c2507f321d91b2ed2780b poslib-1.0.2.ebuild 707
MD5 45dc6558f375023f43e3aecc1dd5f834 poslib-1.0.4.ebuild 710
+MD5 ef2c17f0c7960d5d4c877960f036f8e0 poslib-1.0.6.ebuild 751
MD5 e80f623ba5c3c99130eb4cc24a541eb2 ChangeLog 1132
MD5 ca160035368973903394d90e1506ff21 metadata.xml 566
MD5 b493e16dfac7d1f51e445d635c036dfa poslib-1.0.5.ebuild 749
MD5 d26ec63ce97f5c2e14c08762a62ba2f7 files/digest-poslib-1.0.2 64
MD5 6315a7c375173375b5c62450bdf189e2 files/digest-poslib-1.0.4 64
MD5 493d2924243ec303551d83a251ba508b files/digest-poslib-1.0.5 64
+MD5 8b3b8697695a69ad7041944215efa104 files/digest-poslib-1.0.6 64
diff --git a/dev-cpp/poslib/files/digest-poslib-1.0.2 b/dev-cpp/poslib/files/digest-poslib-1.0.2
deleted file mode 100644
index 67ffdb0096ef..000000000000
--- a/dev-cpp/poslib/files/digest-poslib-1.0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 49de55d4f1efc2f1c81912a3bcd7bee7 poslib-1.0.2.tar.gz 255360
diff --git a/dev-cpp/poslib/files/digest-poslib-1.0.6 b/dev-cpp/poslib/files/digest-poslib-1.0.6
new file mode 100644
index 000000000000..1af512b7726a
--- /dev/null
+++ b/dev-cpp/poslib/files/digest-poslib-1.0.6
@@ -0,0 +1 @@
+MD5 c1b0c48625191017904b7c9aa0365ef2 poslib-1.0.6.tar.gz 397622
diff --git a/dev-cpp/poslib/poslib-1.0.2.ebuild b/dev-cpp/poslib/poslib-1.0.6.ebuild
index 5a2918855594..abd2cdeac174 100644
--- a/dev-cpp/poslib/poslib-1.0.2.ebuild
+++ b/dev-cpp/poslib/poslib-1.0.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/poslib-1.0.2.ebuild,v 1.5 2004/06/29 15:16:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/poslib/poslib-1.0.6.ebuild,v 1.1 2004/12/31 13:39:49 matsuu Exp $
+
+inherit flag-o-matic
DESCRIPTION="A library for creating C++ programs using the Domain Name System"
HOMEPAGE="http://www.posadis.org/projects/poslib.php"
@@ -8,14 +10,16 @@ SRC_URI="mirror://sourceforge/posadis/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64"
+KEYWORDS="~x86 ~amd64 ~ppc"
IUSE="ipv6"
DEPEND="virtual/libc"
src_compile() {
+ append-flags -funsigned-char
+
econf \
- --with-cxxflags="${CXXFLAGS} -funsigned-char" \
+ --with-cxxflags="${CXXFLAGS}" \
`use_enable ipv6` || die
emake || die
}