summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-05-04 10:37:19 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-05-04 10:37:19 +0000
commit0343a18c74e982f9aaec0858cfd1ce03dd4d74c1 (patch)
tree0fe81d4268e73ad89ed186b7040d432323548f94 /dev-cpp
parentdev-python/pytables: Converted to new python r1 eclasses (diff)
downloadgentoo-2-0343a18c74e982f9aaec0858cfd1ce03dd4d74c1.tar.gz
gentoo-2-0343a18c74e982f9aaec0858cfd1ce03dd4d74c1.tar.bz2
gentoo-2-0343a18c74e982f9aaec0858cfd1ce03dd4d74c1.zip
remove libdir hack and use config switch instead
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/luabind/ChangeLog5
-rw-r--r--dev-cpp/luabind/luabind-0.9.1.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/dev-cpp/luabind/ChangeLog b/dev-cpp/luabind/ChangeLog
index 0ff763fb0c5d..0df1271a11bc 100644
--- a/dev-cpp/luabind/ChangeLog
+++ b/dev-cpp/luabind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/luabind
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/ChangeLog,v 1.1 2013/05/02 21:56:13 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/ChangeLog,v 1.2 2013/05/04 10:37:19 hasufell Exp $
+
+ 04 May 2013; Julian Ospald <hasufell@gentoo.org> luabind-0.9.1.ebuild:
+ remove libdir hack and use config switch instead
*luabind-0.9.1 (02 May 2013)
diff --git a/dev-cpp/luabind/luabind-0.9.1.ebuild b/dev-cpp/luabind/luabind-0.9.1.ebuild
index 7a0453705f79..85be8e1369f0 100644
--- a/dev-cpp/luabind/luabind-0.9.1.ebuild
+++ b/dev-cpp/luabind/luabind-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.1 2013/05/02 21:56:13 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.2 2013/05/04 10:37:19 hasufell Exp $
# NOTE: cross compiling is probably broken
@@ -31,6 +31,7 @@ src_compile() {
bjam release \
-d+2 \
--prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
cflags="${CFLAGS}" \
linkflags="${LDFLAGS}" \
link=shared || die "compile failed"
@@ -40,13 +41,11 @@ src_install() {
bjam release \
-d+2 \
--prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
cflags="${CFLAGS}" \
linkflags="${LDFLAGS}" \
link=shared \
install || die "compile failed"
-
- # no idea how to fix that in Jamfile
- mv "${ED}"/usr/lib "${ED}"/usr/$(get_libdir)
}
# generally, this really sucks, patches welcome