summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-07 12:56:53 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-07 12:56:53 +0000
commit25497a4ee5c29feed5ac3841df02ff3d7f9b7042 (patch)
tree104731a3aeb066396c3e94b505a7a9127f41f5b7 /dev-cpp
parentVersion bump. (diff)
downloadgentoo-2-25497a4ee5c29feed5ac3841df02ff3d7f9b7042.tar.gz
gentoo-2-25497a4ee5c29feed5ac3841df02ff3d7f9b7042.tar.bz2
gentoo-2-25497a4ee5c29feed5ac3841df02ff3d7f9b7042.zip
Add a release version now that the build system fixes have made it into the release.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libjson-rpc-cpp/ChangeLog9
-rw-r--r--dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.5.0.ebuild50
-rw-r--r--dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild10
3 files changed, 63 insertions, 6 deletions
diff --git a/dev-cpp/libjson-rpc-cpp/ChangeLog b/dev-cpp/libjson-rpc-cpp/ChangeLog
index be07d981c9df..b31f7a8f17b3 100644
--- a/dev-cpp/libjson-rpc-cpp/ChangeLog
+++ b/dev-cpp/libjson-rpc-cpp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/libjson-rpc-cpp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libjson-rpc-cpp/ChangeLog,v 1.1 2015/04/04 10:07:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libjson-rpc-cpp/ChangeLog,v 1.2 2015/04/07 12:56:53 mgorny Exp $
+
+*libjson-rpc-cpp-0.5.0 (07 Apr 2015)
+
+ 07 Apr 2015; Michał Górny <mgorny@gentoo.org> +libjson-rpc-cpp-0.5.0.ebuild,
+ libjson-rpc-cpp-9999.ebuild:
+ Add a release version now that the build system fixes have made it into the
+ release.
*libjson-rpc-cpp-9999 (04 Apr 2015)
diff --git a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.5.0.ebuild b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.5.0.ebuild
new file mode 100644
index 000000000000..bb37f684b4af
--- /dev/null
+++ b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.5.0.ebuild,v 1.1 2015/04/07 12:56:53 mgorny Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="JSON-RPC (1.0 & 2.0) framework for C++"
+HOMEPAGE="https://github.com/cinemast/libjson-rpc-cpp"
+SRC_URI="https://github.com/cinemast/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +http-client +http-server +stubgen test"
+
+RDEPEND="
+ dev-libs/jsoncpp:=
+ http-client? ( net-misc/curl:= )
+ http-server? ( net-libs/libmicrohttpd:= )
+ stubgen? ( dev-libs/argtable:= )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/boost )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DHTTP_CLIENT=$(usex http-client)
+ -DHTTP_SERVER=$(usex http-server)
+ # they are not installed
+ -DCOMPILE_EXAMPLES=NO
+ -DCOMPILE_STUBGEN=$(usex stubgen)
+ -DCOMPILE_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && emake -C "${BUILD_DIR}" doc
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && dodoc -r "${BUILD_DIR}"/doc/html
+}
diff --git a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
index c4f48ca9befa..01a8c6c1c1db 100644
--- a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
+++ b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild,v 1.1 2015/04/04 10:07:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-9999.ebuild,v 1.2 2015/04/07 12:56:53 mgorny Exp $
EAPI=5
@@ -18,10 +18,10 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc +http-client +http-server +stubgen test"
RDEPEND="
- dev-libs/jsoncpp
- http-client? ( net-misc/curl )
- http-server? ( net-libs/libmicrohttpd )
- stubgen? ( dev-libs/argtable )"
+ dev-libs/jsoncpp:=
+ http-client? ( net-misc/curl:= )
+ http-server? ( net-libs/libmicrohttpd:= )
+ stubgen? ( dev-libs/argtable:= )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( dev-libs/boost )"