summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-03-06 22:05:30 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-03-06 22:05:30 +0000
commit87dff21d6ea1c3eea49142452f6d8505bdcdf670 (patch)
tree588a1bee08b00eea92f83681806a77e91d8d6485 /dev-cpp
parentamd64 stable, bug 540290 (diff)
downloadgentoo-2-87dff21d6ea1c3eea49142452f6d8505bdcdf670.tar.gz
gentoo-2-87dff21d6ea1c3eea49142452f6d8505bdcdf670.tar.bz2
gentoo-2-87dff21d6ea1c3eea49142452f6d8505bdcdf670.zip
fixed install without doc (bug #542022)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/icnc/ChangeLog5
-rw-r--r--dev-cpp/icnc/icnc-1.0.100.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-cpp/icnc/ChangeLog b/dev-cpp/icnc/ChangeLog
index de2fbd452a63..950bd5fea5ec 100644
--- a/dev-cpp/icnc/ChangeLog
+++ b/dev-cpp/icnc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/icnc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/icnc/ChangeLog,v 1.2 2015/02/08 20:41:08 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/icnc/ChangeLog,v 1.3 2015/03/06 22:05:30 ottxor Exp $
+
+ 06 Mar 2015; Christoph Junghans <ottxor@gentoo.org> icnc-1.0.100.ebuild:
+ fixed install without doc (bug #542022)
08 Feb 2015; Christoph Junghans <ottxor@gentoo.org> icnc-1.0.100.ebuild:
fixed deps and install of api docu (bug #539318)
diff --git a/dev-cpp/icnc/icnc-1.0.100.ebuild b/dev-cpp/icnc/icnc-1.0.100.ebuild
index 943e9f5323fb..709a61143443 100644
--- a/dev-cpp/icnc/icnc-1.0.100.ebuild
+++ b/dev-cpp/icnc/icnc-1.0.100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/icnc/icnc-1.0.100.ebuild,v 1.2 2015/02/08 20:41:08 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/icnc/icnc-1.0.100.ebuild,v 1.3 2015/03/06 22:05:30 ottxor Exp $
EAPI=5
@@ -40,6 +40,7 @@ src_configure() {
local mycmakeargs=(
$(cmake-utils_use mpi BUILD_LIBS_FOR_MPI)
-DLIB=$(get_libdir)
+ $(cmake-utils_use_find_package doc Doxygen)
)
cmake-utils_src_configure
if use test ; then
@@ -65,8 +66,7 @@ src_install() {
insinto /usr/share/doc/${P}/html
doins -r "${ED}"/usr/doc/api/*
fi
- rm -fr "${ED}"/usr/doc/api
- rmdir "${ED}"/usr/doc || die
+ rm -fr "${ED}"/usr/doc
if use examples ; then
insinto /usr/share/${PN}/examples
doins -r "${ED}"/usr/samples/*