summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-13 17:38:11 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-13 17:38:11 +0000
commit2151c72c0cde37570e359e44ce58b4af13353ff8 (patch)
treebbdd95c48cb0f70b638cf9bdf8a19a4ba59b4baa /dev-db/firebird
parentstable x86, bug 280379 (diff)
downloadgentoo-2-2151c72c0cde37570e359e44ce58b4af13353ff8.tar.gz
gentoo-2-2151c72c0cde37570e359e44ce58b4af13353ff8.tar.bz2
gentoo-2-2151c72c0cde37570e359e44ce58b4af13353ff8.zip
Fixing gcc 4.4.0 and icu 4.2 build error, bug #270154 , patch thanks to Steffen 'j0inty' Stollfuß
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-db/firebird')
-rw-r--r--dev-db/firebird/ChangeLog10
-rw-r--r--dev-db/firebird/files/firebird-2.1.1.17910.0-gcc-icu-declare.patch27
-rw-r--r--dev-db/firebird/firebird-2.1.1.17910.0.ebuild4
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-db/firebird/ChangeLog b/dev-db/firebird/ChangeLog
index 20402a01d185..c9c3df228b7d 100644
--- a/dev-db/firebird/ChangeLog
+++ b/dev-db/firebird/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/firebird
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.97 2009/01/18 22:03:05 jsbronder Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.98 2009/08/13 17:38:10 vostorga Exp $
+
+ 13 Aug 2009; Víctor Ostorga <vostorga@gentoo.org>
+ firebird-2.1.1.17910.0.ebuild,
+ +files/firebird-2.1.1.17910.0-gcc-icu-declare.patch:
+ Fixing gcc 4.4.0 and icu 4.2 build error, bug #270154
+ patch thanks to Steffen 'j0inty' Stollfuß <steffen@stollfuss.net>
18 Jan 2009; Justin Bronder <jsbronder@gentoo.org>
firebird-2.0.3.12981.0-r6.ebuild, firebird-2.0.3.12981.0-r7.ebuild,
diff --git a/dev-db/firebird/files/firebird-2.1.1.17910.0-gcc-icu-declare.patch b/dev-db/firebird/files/firebird-2.1.1.17910.0-gcc-icu-declare.patch
new file mode 100644
index 000000000000..1e0fc093668e
--- /dev/null
+++ b/dev-db/firebird/files/firebird-2.1.1.17910.0-gcc-icu-declare.patch
@@ -0,0 +1,27 @@
+--- src/common/classes/alloc.h.old 2009-07-09 13:04:14.000000000 +0200
++++ src/common/classes/alloc.h 2009-07-09 13:05:37.000000000 +0200
+@@ -48,6 +48,8 @@
+ stdlib.h (EKU) */
+ #endif
+
++#include <new>
++
+ #ifdef _MSC_VER
+ #define THROW_BAD_ALLOC
+ #else
+@@ -448,15 +450,6 @@
+ );
+ }
+
+-inline void* operator new(size_t, void* ptr) throw()
+-{
+- return ptr;
+-}
+-inline void* operator new[](size_t, void* ptr) throw()
+-{
+- return ptr;
+-}
+-
+ inline void operator delete(void* mem) throw()
+ {
+ Firebird::MemoryPool::globalFree(mem);
diff --git a/dev-db/firebird/firebird-2.1.1.17910.0.ebuild b/dev-db/firebird/firebird-2.1.1.17910.0.ebuild
index b04a40723384..1a4f0677a3c4 100644
--- a/dev-db/firebird/firebird-2.1.1.17910.0.ebuild
+++ b/dev-db/firebird/firebird-2.1.1.17910.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-2.1.1.17910.0.ebuild,v 1.2 2009/01/18 22:03:05 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-2.1.1.17910.0.ebuild,v 1.3 2009/08/13 17:38:10 vostorga Exp $
inherit flag-o-matic eutils autotools versionator
@@ -120,6 +120,8 @@ src_unpack() {
find "${S}" -name \*.sh -print0 | xargs -0 chmod +x
rm -rf "${S}"/extern/{editline,icu}
+ epatch "${FILESDIR}/${P}-gcc-icu-declare.patch"
+
eautoreconf
}