summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-16 16:15:40 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-16 16:15:40 +0000
commitc354d26e376233e8ddf2b0d815d9b21963cf4baf (patch)
tree208eb6c5668234654e104fc3044d6b5a62ee156d /dev-db/flamerobin
parentMarked stable on amd64 for bug #177213 (diff)
downloadgentoo-2-c354d26e376233e8ddf2b0d815d9b21963cf4baf.tar.gz
gentoo-2-c354d26e376233e8ddf2b0d815d9b21963cf4baf.tar.bz2
gentoo-2-c354d26e376233e8ddf2b0d815d9b21963cf4baf.zip
Pass wx-config location to econf for bug #178713.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-db/flamerobin')
-rw-r--r--dev-db/flamerobin/ChangeLog6
-rw-r--r--dev-db/flamerobin/flamerobin-0.7.5-r1.ebuild12
-rw-r--r--dev-db/flamerobin/flamerobin-0.7.6.ebuild12
3 files changed, 21 insertions, 9 deletions
diff --git a/dev-db/flamerobin/ChangeLog b/dev-db/flamerobin/ChangeLog
index 620e68ce7be1..17c619a4a9ab 100644
--- a/dev-db/flamerobin/ChangeLog
+++ b/dev-db/flamerobin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/flamerobin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/ChangeLog,v 1.7 2007/01/08 18:13:08 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/ChangeLog,v 1.8 2007/05/16 16:15:40 dirtyepic Exp $
+
+ 16 May 2007; Ryan Hill <dirtyepic@gentoo.org> flamerobin-0.7.5-r1.ebuild,
+ flamerobin-0.7.6.ebuild:
+ Pass wx-config location to econf for bug #178713.
08 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
flamerobin-0.7.6.ebuild:
diff --git a/dev-db/flamerobin/flamerobin-0.7.5-r1.ebuild b/dev-db/flamerobin/flamerobin-0.7.5-r1.ebuild
index aaf1683b1f3d..44d7a77826bb 100644
--- a/dev-db/flamerobin/flamerobin-0.7.5-r1.ebuild
+++ b/dev-db/flamerobin/flamerobin-0.7.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/flamerobin-0.7.5-r1.ebuild,v 1.2 2006/11/07 01:17:35 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/flamerobin-0.7.5-r1.ebuild,v 1.3 2007/05/16 16:15:40 dirtyepic Exp $
inherit eutils wxwidgets
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-RDEPEND=">=x11-libs/wxGTK-2.6.0
+RDEPEND="=x11-libs/wxGTK-2.6*
dev-db/firebird"
DEPEND="${RDEPEND}"
@@ -26,7 +26,11 @@ pkg_setup() {
}
src_compile() {
local myconf
- myconf="${myconf} --disable-shared --disable-debug --with-wx=yes"
+ myconf="${myconf} \
+ --disable-shared \
+ --disable-debug \
+ --with-wx=yes \
+ --with-wx-config=${WX_CONFIG}"
econf ${myconf} || die "Could not configure FlameRobin"
emake || die "error during make"
}
diff --git a/dev-db/flamerobin/flamerobin-0.7.6.ebuild b/dev-db/flamerobin/flamerobin-0.7.6.ebuild
index cdb1e5488789..f778e0d7cfe5 100644
--- a/dev-db/flamerobin/flamerobin-0.7.6.ebuild
+++ b/dev-db/flamerobin/flamerobin-0.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/flamerobin-0.7.6.ebuild,v 1.2 2007/01/08 18:13:08 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/flamerobin-0.7.6.ebuild,v 1.3 2007/05/16 16:15:40 dirtyepic Exp $
inherit eutils wxwidgets
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE="doc"
-RDEPEND=">=x11-libs/wxGTK-2.6.0
+RDEPEND="=x11-libs/wxGTK-2.6*
dev-db/firebird"
DEPEND="${RDEPEND}"
@@ -21,12 +21,16 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${P}-src"
pkg_setup() {
- export WX_GTK_VER="2.6"
+ export WX_GTK_VER="2.6"
need-wxwidgets gtk2
}
src_compile() {
local myconf
- myconf="${myconf} --disable-shared --disable-debug --with-wx=yes"
+ myconf="${myconf} \
+ --disable-shared \
+ --disable-debug \
+ --with-wx=yes \
+ --with-wx-config=${WX_CONFIG}"
econf ${myconf} || die "Could not configure FlameRobin"
emake || die "error during make"
}