summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-02-21 03:34:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-02-21 03:34:49 +0000
commit234b3e21c01bf1138322b5733495edde757f5884 (patch)
tree9252cf2a81811a57aac2e9f6fbb4b80881c74aad /dev-db/hyperdex
parentBump (diff)
downloadgentoo-2-234b3e21c01bf1138322b5733495edde757f5884.tar.gz
gentoo-2-234b3e21c01bf1138322b5733495edde757f5884.tar.bz2
gentoo-2-234b3e21c01bf1138322b5733495edde757f5884.zip
Bump, restrict tests as they fail to build
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/hyperdex')
-rw-r--r--dev-db/hyperdex/ChangeLog7
-rw-r--r--dev-db/hyperdex/hyperdex-1.1.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-db/hyperdex/ChangeLog b/dev-db/hyperdex/ChangeLog
index fbda1b45dd24..9776bcfe136c 100644
--- a/dev-db/hyperdex/ChangeLog
+++ b/dev-db/hyperdex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/hyperdex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.15 2014/02/10 06:52:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.16 2014/02/21 03:34:49 patrick Exp $
+
+*hyperdex-1.1.0 (21 Feb 2014)
+
+ 21 Feb 2014; Patrick Lauer <patrick@gentoo.org> +hyperdex-1.1.0.ebuild:
+ Bump, restrict tests as they fail to build
10 Feb 2014; Patrick Lauer <patrick@gentoo.org> hyperdex-1.0.5.ebuild:
Tests work again, so unrestrict
diff --git a/dev-db/hyperdex/hyperdex-1.1.0.ebuild b/dev-db/hyperdex/hyperdex-1.1.0.ebuild
new file mode 100644
index 000000000000..4b61ab1e559c
--- /dev/null
+++ b/dev-db/hyperdex/hyperdex-1.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.1.0.ebuild,v 1.1 2014/02/21 03:34:49 patrick Exp $
+EAPI=5
+
+RESTRICT="test"
+PYTHON_DEPEND="2:2.6"
+inherit eutils python
+
+DESCRIPTION="A searchable distributed Key-Value Store"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+python"
+# need to add ruby and java useflags too
+
+DEPEND="dev-cpp/glog
+ dev-cpp/sparsehash
+ dev-libs/cityhash
+ dev-libs/libpo6
+ dev-libs/libe
+ dev-libs/busybee
+ dev-libs/popt
+ dev-libs/replicant"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf --disable-static \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
+}