summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-08-29 16:02:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-08-29 16:02:49 +0000
commitc1575fbb9067390b5e0d5a523636513478aecb9f (patch)
tree8673328486ef70327dccb656319ad8c1940cb7b8 /dev-db/libdbi-drivers
parentBump per bug #465716. (diff)
downloadgentoo-2-c1575fbb9067390b5e0d5a523636513478aecb9f.tar.gz
gentoo-2-c1575fbb9067390b5e0d5a523636513478aecb9f.tar.bz2
gentoo-2-c1575fbb9067390b5e0d5a523636513478aecb9f.zip
Bump per bug #465716.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/libdbi-drivers')
-rw-r--r--dev-db/libdbi-drivers/ChangeLog8
-rw-r--r--dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch22
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild89
3 files changed, 118 insertions, 1 deletions
diff --git a/dev-db/libdbi-drivers/ChangeLog b/dev-db/libdbi-drivers/ChangeLog
index 7adecc206502..284fe5584a3a 100644
--- a/dev-db/libdbi-drivers/ChangeLog
+++ b/dev-db/libdbi-drivers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libdbi-drivers
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.54 2013/05/14 02:55:38 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.55 2013/08/29 16:02:49 robbat2 Exp $
+
+*libdbi-drivers-0.9.0 (29 Aug 2013)
+
+ 29 Aug 2013; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libdbi-drivers-0.9.0-doc-build-fix.patch, +libdbi-drivers-0.9.0.ebuild:
+ Bump per bug #465716.
14 May 2013; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+files/libdbi-drivers-0.8.3-fix-ac-macro.patch,
diff --git a/dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch b/dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch
new file mode 100644
index 000000000000..d0d74221fdb0
--- /dev/null
+++ b/dev-db/libdbi-drivers/files/libdbi-drivers-0.9.0-doc-build-fix.patch
@@ -0,0 +1,22 @@
+diff -Nuar libdbi-drivers-0.9.0.orig/configure.in libdbi-drivers-0.9.0/configure.in
+--- libdbi-drivers-0.9.0.orig/configure.in 2013-03-11 23:41:05.000000000 +0000
++++ libdbi-drivers-0.9.0/configure.in 2013-08-29 15:52:57.632105403 +0000
+@@ -165,14 +165,13 @@
+ dnl See whether to build the docs
+ dnl ==============================
+
+-ac_docs="YES"
++ac_docs="yes"
+ AC_ARG_ENABLE(docs,
+ [ --disable-docs do not build and install the documentation.],
+- [ if test "$enable_docs" = "no"; then
+- ac_docs="NO"
+- fi])
++ [ ac_docs="$enableval" ],
++ [ ac_docs="no" ])
+
+-if test "$ac_docs" = "YES"; then
++if test "$ac_docs" = "yes"; then
+ docs_subdirs="doc"
+ else
+ docs_subdirs=""
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild
new file mode 100644
index 000000000000..b5b3f323e40d
--- /dev/null
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild,v 1.1 2013/08/29 16:02:49 robbat2 Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
+HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
+LICENSE="LGPL-2.1"
+
+IUSE="bindist doc firebird mysql oci8 postgres +sqlite static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+SLOT=0
+
+RDEPEND="
+ >=dev-db/libdbi-0.9.0
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-text/openjade )
+"
+
+
+REQUIRED_USE="
+ firebird? ( !bindist )
+ || ( mysql postgres sqlite firebird oci8 )
+"
+
+DOCS="AUTHORS ChangeLog NEWS README README.osx TODO"
+
+pkg_setup() {
+ use oci8 && [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
+}
+
+src_prepare() {
+ #"${FILESDIR}"/${P}-fix-ac-macro.patch \
+ #"${FILESDIR}"/${PN}-0.8.3-oracle-build-fix.patch \
+ #"${FILESDIR}"/${PN}-0.8.3-firebird-fix.patch
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.0-doc-build-fix.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+ # WARNING: the configure script does NOT work correctly
+ # --without-$driver does NOT work
+ # so do NOT use `use_with...`
+ # Future additions:
+ # msql
+ # freetds
+ # ingres
+ # db2
+ use mysql && myconf+=" --with-mysql"
+ use postgres && myconf+=" --with-pgsql"
+ use sqlite && myconf+=" --with-sqlite3"
+ use firebird && myconf+=" --with-firebird"
+ if use oci8; then
+ [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
+ myconf+=" --with-oracle-dir=${ORACLE_HOME} --with-oracle"
+ fi
+
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_test() {
+ if [[ -z "${WANT_INTERACTIVE_TESTS}" ]]; then
+ ewarn "Tests disabled due to interactivity."
+ ewarn "Run with WANT_INTERACTIVE_TESTS=1 if you want them."
+ return 0
+ fi
+ einfo "Running interactive tests"
+ emake check
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}