summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-08-25 19:34:11 +0000
committerHans de Graaff <graaff@gentoo.org>2014-08-25 19:34:11 +0000
commitc2b1634fb8e6d926bdc4dfeb16abd962dc950107 (patch)
tree4a5577b666ba09b9c91f5a4d94b47c7f8b0445a2 /dev-db/mysql-workbench
parentNMU: Version bump. See bug #511460. Generate manpage on buildtime. Add init s... (diff)
downloadgentoo-2-c2b1634fb8e6d926bdc4dfeb16abd962dc950107.tar.gz
gentoo-2-c2b1634fb8e6d926bdc4dfeb16abd962dc950107.tar.bz2
gentoo-2-c2b1634fb8e6d926bdc4dfeb16abd962dc950107.zip
Add patch to compile against mariadb 10, fixing bug 520664.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-db/mysql-workbench')
-rw-r--r--dev-db/mysql-workbench/ChangeLog6
-rw-r--r--dev-db/mysql-workbench/files/mysql-workbench-6.1.7-mysql_options4.patch29
-rw-r--r--dev-db/mysql-workbench/mysql-workbench-6.1.7.ebuild5
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-db/mysql-workbench/ChangeLog b/dev-db/mysql-workbench/ChangeLog
index 53c27f5d5bf5..816d1a1af1e6 100644
--- a/dev-db/mysql-workbench/ChangeLog
+++ b/dev-db/mysql-workbench/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/mysql-workbench
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-workbench/ChangeLog,v 1.96 2014/07/12 09:12:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-workbench/ChangeLog,v 1.97 2014/08/25 19:34:11 graaff Exp $
+
+ 25 Aug 2014; Hans de Graaff <graaff@gentoo.org> mysql-workbench-6.1.7.ebuild,
+ +files/mysql-workbench-6.1.7-mysql_options4.patch:
+ Add patch to compile against mariadb 10, fixing bug 520664.
12 Jul 2014; Hans de Graaff <graaff@gentoo.org> mysql-workbench-6.1.7.ebuild,
+files/mysql-workbench-6.1.7-wbcopytables.patch:
diff --git a/dev-db/mysql-workbench/files/mysql-workbench-6.1.7-mysql_options4.patch b/dev-db/mysql-workbench/files/mysql-workbench-6.1.7-mysql_options4.patch
new file mode 100644
index 000000000000..e0dbc2bef5e0
--- /dev/null
+++ b/dev-db/mysql-workbench/files/mysql-workbench-6.1.7-mysql_options4.patch
@@ -0,0 +1,29 @@
+Patch taken from opensuse:
+https://www.mail-archive.com/opensuse-commit@opensuse.org/msg60296.html
+
+Modified to be conditional on MARIADB_BASE_VERSION
+
+++++++ mysql-workbench-mysql_options4.patch ++++++
+diff --git a/plugins/migration/copytable/copytable.cpp
+b/plugins/migration/copytable/copytable.cpp
+index b273287..77c227b 100644
+--- a/plugins/migration/copytable/copytable.cpp
++++ b/plugins/migration/copytable/copytable.cpp
+@@ -1633,12 +1633,17 @@ MySQLCopyDataTarget::MySQLCopyDataTarget(const
+ std::string &hostname, int port,
+ _truncate = false;
+
+ mysql_init(&_mysql);
++ /* This is optional has compiled in for MySQL >= 5.6.6
++ * Looks like MariaDB does not support this as supposed,
++ * so disable completly. */
++#ifndef MARIADB_BASE_VERSION
+ #if defined(MYSQL_VERSION_MAJOR) && defined(MYSQL_VERSION_MINOR) && defined(MYSQL_VERSION_PATCH)
+ #if MYSQL_CHECK_VERSION(5,6,6)
+ mysql_options4(&_mysql, MYSQL_OPT_CONNECT_ATTR_ADD, "program_name", app_name.c_str());
+ #endif
+ #endif
++#endif
+
+ // _bulk_insert_record is used to prepare a single record string, the connection
+ // is needed to escape binary data properly
diff --git a/dev-db/mysql-workbench/mysql-workbench-6.1.7.ebuild b/dev-db/mysql-workbench/mysql-workbench-6.1.7.ebuild
index f234b248c129..1b0d574b92a5 100644
--- a/dev-db/mysql-workbench/mysql-workbench-6.1.7.ebuild
+++ b/dev-db/mysql-workbench/mysql-workbench-6.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-workbench/mysql-workbench-6.1.7.ebuild,v 1.2 2014/07/12 09:12:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-workbench/mysql-workbench-6.1.7.ebuild,v 1.3 2014/08/25 19:34:11 graaff Exp $
EAPI=5
GCONF_DEBUG="no"
@@ -67,7 +67,8 @@ S="${WORKDIR}"/"${MY_P}"
src_prepare() {
## Patch CMakeLists.txt
epatch "${FILESDIR}/${PN}-6.0.8-CMakeLists.patch" \
- "${FILESDIR}/${P}-wbcopytables.patch"
+ "${FILESDIR}/${P}-wbcopytables.patch" \
+ "${FILESDIR}/${P}-mysql_options4.patch"
## remove hardcoded CXXFLAGS
sed -i -e 's/-O0 -g3//' ext/scintilla/gtk/CMakeLists.txt || die